Bug 678604 - Wrong Cursor when widget become native. on X11
Summary: Wrong Cursor when widget become native. on X11
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qt
Version: 6.0
Hardware: All
OS: Linux
low
medium
Target Milestone: rc
: ---
Assignee: Ngo Than
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-18 15:21 UTC by Ben Breard
Modified: 2013-03-21 09:51 UTC (History)
1 user (show)

Fixed In Version: qt-4.6.2-25.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-07 15:01:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1246 normal SHIPPED_LIVE qt bug fix update 2012-09-07 19:00:03 UTC

Description Ben Breard 2011-02-18 15:21:09 UTC
Description of problem:
QT 4.6 had a known bug causing the mouse pointer to disappear in apps under certain circumstances that arise fairly frequently in Konversation

Version-Release number of selected component (if applicable):
qt-4.6.2-16.el6.x86_64

How reproducible: 100%


Steps to Reproduce: Easy to test in Konversation
1. paste multiple lines of text.
2. After the warning dialog the mouse pointer will be hidden while selecting tabs.
3. The app will need to be restarted.


Additional info: Fixed in upstream QT 4.7. 

I believe this is the fix for Fedora.
http://pkgs.fedoraproject.org/gitweb/?p=qt.git;a=commit;h=2547722966971f25eb66f46021ff2410a9ba6bf0

Hopefully it's not too difficult to backport to QT 4.6 in RHEL6 as this is really annoying for all 5 of us who use KDE.

Comment 2 RHEL Product and Program Management 2011-02-18 15:38:13 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 15 errata-xmlrpc 2012-09-07 15:01:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1246.html


Note You need to log in before you can comment on or make changes to this bug.