Bug 678607 - AttributeError: 'NoneType' object has no attribute 'format'
AttributeError: 'NoneType' object has no attribute 'format'
Status: CLOSED DUPLICATE of bug 672030
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
anaconda_trace_hash:9b2ddec9d5cd6e4ed...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-18 10:27 EST by James Laska
Modified: 2013-09-02 02:53 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-18 14:44:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (1.08 MB, text/plain)
2011-02-18 10:27 EST, James Laska
no flags Details
Attached traceback automatically from anaconda. (387.19 KB, text/plain)
2011-02-18 12:20 EST, Adam Williamson
no flags Details
Attached traceback automatically from anaconda. (204.41 KB, text/plain)
2011-02-18 23:05 EST, Dennis Gilmore
no flags Details
Attached traceback automatically from anaconda. (206.85 KB, text/plain)
2011-02-20 05:34 EST, masami256
no flags Details
Attached traceback automatically from anaconda. (205.18 KB, text/plain)
2011-02-21 06:16 EST, Athmane Madjoudj
no flags Details

  None (edit)
Description James Laska 2011-02-18 10:27:09 EST
The following was filed automatically by anaconda:
anaconda 15.20 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/livecd.py", line 341, in getMinimumSizeMB
    return self.anaconda.storage.liveImage.format.size
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1027, in sanityCheck
    root.size < self.anaconda.backend.getMinimumSizeMB("/")):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/partitioning.py", line 259, in doAutoPartition
    (errors, warnings) = anaconda.storage.sanityCheck()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1346, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1258, in nextClicked
    self.setScreen ()
AttributeError: 'NoneType' object has no attribute 'format'
Comment 1 James Laska 2011-02-18 10:27:13 EST
Created attachment 479541 [details]
Attached traceback automatically from anaconda.
Comment 2 James Laska 2011-02-18 10:28:32 EST
While trying to retest a custom-built F-15-Alpha live image (near RC time), I hit bug#663294 while attempting to install.  I re-ran liveinst and attempted to install again, and encountered this failure.
Comment 3 Adam Williamson 2011-02-18 12:20:50 EST
Created attachment 479572 [details]
Attached traceback automatically from anaconda.
Comment 4 Adam Williamson 2011-02-18 12:22:48 EST
I hit this also, following much the same process as jlaska - build a live image with latest kernel (to avoid 672265) and attempt to install, using 'use entire disk' partition scheme choice. Testing in a VM using an XFCE live image.
Comment 5 Brian Lane 2011-02-18 14:44:54 EST

*** This bug has been marked as a duplicate of bug 672030 ***
Comment 6 Dennis Gilmore 2011-02-18 23:05:09 EST
Created attachment 479644 [details]
Attached traceback automatically from anaconda.
Comment 7 masami256 2011-02-20 05:34:20 EST
Created attachment 479751 [details]
Attached traceback automatically from anaconda.
Comment 8 Athmane Madjoudj 2011-02-21 06:16:01 EST
Created attachment 479872 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.