Bug 678640 - [abrt] gmixer-1.3-19.fc14: gmixer:892:_tray_simple_click:AttributeError: 'GMixer' object has no attribute '_eventbox'
Summary: [abrt] gmixer-1.3-19.fc14: gmixer:892:_tray_simple_click:AttributeError: 'GMi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gmixer
Version: 14
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:38ca71f0
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-18 17:42 UTC by Fred Q.
Modified: 2011-04-11 05:14 UTC (History)
32 users (show)

Fixed In Version: gmixer-1.3-20.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-06 22:31:53 UTC


Attachments (Terms of Use)
File: backtrace (385 bytes, text/plain)
2011-02-18 17:42 UTC, Fred Q.
no flags Details
three icons (25.58 KB, image/png)
2011-03-21 19:56 UTC, Riccardo Angelino
no flags Details
window (111.82 KB, image/png)
2011-03-21 20:03 UTC, Riccardo Angelino
no flags Details
proposed patch (2.17 KB, patch)
2011-03-27 02:24 UTC, Thomas Moschny
no flags Details | Diff
proposed patch (2.34 KB, patch)
2011-03-28 21:15 UTC, Thomas Moschny
no flags Details | Diff

Description Fred Q. 2011-02-18 17:42:25 UTC
abrt version: 1.1.17
architecture: x86_64
cmdline: /usr/bin/python -OO /usr/bin/gmixer -d
component: gmixer
executable: /usr/bin/gmixer
kernel: 2.6.35.11-83.fc14.x86_64
package: gmixer-1.3-19.fc14
reason: gmixer:892:_tray_simple_click:AttributeError: 'GMixer' object has no attribute '_eventbox'
release: Fedora release 14 (Laughlin)
time: 1298050783
uid: 500

backtrace
-----
gmixer:892:_tray_simple_click:AttributeError: 'GMixer' object has no attribute '_eventbox'

Traceback (most recent call last):
  File "/usr/bin/gmixer", line 892, in _tray_simple_click
    self._popup.position_on(self._eventbox)
AttributeError: 'GMixer' object has no attribute '_eventbox'

Local variables in innermost frame:
self: <GMixer object at 0x142e410 (GObject at 0x14799a0)>

How to reproduce
-----
1.open gmixer
2.
3.

Comment 1 Fred Q. 2011-02-18 17:42:27 UTC
Created attachment 479576 [details]
File: backtrace

Comment 2 Adam Williamson 2011-02-18 17:48:20 UTC
Package: gmixer-1.3-20.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. clicked on gmixer icon in gnome-shell notification area
2.
3.


Comment
-----
granted, this is a really dumb way to use gmixer.

Comment 3 Jeremy Baudoin 2011-02-19 14:16:55 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.on startup

3.

Comment 4 Jeremy Baudoin 2011-02-19 17:05:44 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.on startup

3.

Comment 5 Jeremy Baudoin 2011-02-19 17:56:49 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.on startup

3.

Comment 6 Christoph Wickert 2011-02-19 21:37:30 UTC
Package: gmixer-1.3-20.fc15
Architecture: i686
OS Release: Fedora release 15 (Rawhide)


How to reproduce
-----
1. install latest LXDE nightly
2. boot & log in
3. click on gmixer's trayicon


Comment
-----
gmixer crashes as soon as you click on it's trayicon. However the main mixer application still works fine.

Comment 7 Jeremy Baudoin 2011-02-22 05:29:41 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. started 

2.
3.

Comment 8 Kerry 2011-03-08 18:56:38 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Restart computer
2. Click gmixer icon on system tray
3. abrt pops up.

Comment 9 meine 2011-03-09 07:43:07 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. started ekiga 3.2.7
2. enabled sound with desktop panel
3. bug notification popped up


Comment
-----
see above. no specific action taken to open or use gmixer intentionally

Comment 10 Kerry 2011-03-09 10:11:06 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Restart computer
2. Click gmixer icon on system tray
3. abrt pops up.

Comment 11 arven979 2011-03-09 11:02:03 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I log in into Gnome.
2. I click on GMixer icon on System Tray
3. I get report that something 'crashed'.
4. When I left-click on GMixer icon, volume adjustment control doesn't appear below the icon, but on the upper-left corner of the screen.




Comment
-----
I started happening only after recent update of gmixer package. Happens *every time* I log in into Gnome. It never happened with the previous package version.

Comment 12 meine 2011-03-09 11:43:22 UTC
I'd like to add that gmixer is installed on my Fedora 14 LXDE version. apparently gmixer is a Gnome application.

Comment 13 Christoph Wickert 2011-03-09 12:03:27 UTC
(In reply to comment #12)
> apparently gmixer is a Gnome application.

It's not, it's GTK+ application just like LXDE:

# rpm -q --requires gmixer
/usr/bin/python  
gstreamer-python  
libatk-1.0.so.0()(64bit)  
libc.so.6()(64bit)  
libc.so.6(GLIBC_2.2.5)(64bit)  
libc.so.6(GLIBC_2.3.4)(64bit)  
libcairo.so.2()(64bit)  
libfontconfig.so.1()(64bit)  
libfreetype.so.6()(64bit)  
libgdk-x11-2.0.so.0()(64bit)  
libgdk_pixbuf-2.0.so.0()(64bit)  
libgio-2.0.so.0()(64bit)  
libglib-2.0.so.0()(64bit)  
libgmodule-2.0.so.0()(64bit)  
libgobject-2.0.so.0()(64bit)  
libgthread-2.0.so.0()(64bit)  
libgtk-x11-2.0.so.0()(64bit)  
libm.so.6()(64bit)  
libpango-1.0.so.0()(64bit)  
libpangocairo-1.0.so.0()(64bit)  
libpangoft2-1.0.so.0()(64bit)  
libpng12.so.0()(64bit)  
libpthread.so.0()(64bit)  
libpython2.7.so.1.0()(64bit)  
librt.so.1()(64bit)  
pygtk2  
python(abi) = 2.7
python-xlib  
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(FileDigests) <= 4.6.0-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rtld(GNU_HASH)  
rpmlib(PayloadIsXz) <= 5.2-1

Not a single gnome dependency.

Comment 14 afsar-servis 2011-03-09 17:28:16 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.1
2.
3.

Comment 15 pepis 2011-03-09 17:34:00 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.work
2.
3.

Comment 16 pepis 2011-03-09 19:15:14 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.work
2.
3.

Comment 17 Calculici 2011-03-09 20:54:05 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.I update the security pachtes.
2.Log out.
3.log in again and it happens when I duble click on GMixer icon for unmute the revers mic in necesary for  tvtime sound.

Comment 18 Jim Shipman 2011-03-10 04:45:56 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I clicked on the volume control applet
2.
3.

Comment 19 Jim Shipman 2011-03-10 06:19:38 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I clicked on the volume control applet
2.
3.

Comment 20 Joel Uckelman 2011-03-10 18:37:24 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Clicked on the mixer icon in the system tray.

Comment 21 ja.spichko 2011-03-10 20:43:13 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Turn the PC on
2. See 2 icons of Gstreamer on the panel
3. Click on one of panels.
4. Bug was detected.


Comment
-----
This bug was detected both desktop and netbook (OS - Russian Fedora Remix 14) after updating.

Comment 22 zayco 2011-03-10 21:23:08 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.nose
2.
3.

Comment 23 Jose Rodriguez 2011-03-11 02:36:52 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Using VLC
2.
3.

Comment 24 Jim Shipman 2011-03-12 01:43:07 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I clicked on the volume control applet
2.
3.

Comment 25 Jose Rodriguez 2011-03-12 02:28:10 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Using Gnome Player
2.
3.

Comment 26 ekram.spam 2011-03-12 10:26:05 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Immediately after starup and login, clicked on the GMixer panel icon
2. Volume slider apears on far left of screen, not under the panel icon
3. Crash is reported

Comment 27 Nuno Dias 2011-03-12 13:36:41 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. click on gmixer
2.
3.


Comment
-----
run gmixer in notitication area

Comment 28 Jose Rodriguez 2011-03-12 17:56:29 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Using Gnome Player
2.
3.

Comment 29 arven979 2011-03-12 18:36:18 UTC
Any chance for fixing this? It seems it affects many, and in the same manner:

1. After startup, clicking on GMixer icon on the panel causes the 'crash'. Note that GMixer doesn't quit. It stays on the panel and is accessible. 

2. Volume slider doesn't appear under the panel icon, but on the upper-left corner of the screen. It doesn't shut after clicking anywhere else on the screen, but only after clicking on GMixer icon on the panel.

3. It happens only once per session, but after every login.

All this started happening after an update several days ago. Before that, GMixer worked just fine.

Comment 30 Christoph Wickert 2011-03-12 19:05:31 UTC
(In reply to comment #29)
> Any chance for fixing this? 

Frankly speaking not, gmixer was recently orphaned in Fedora because the upstream developers have disappeared. The last commit was two years ago, so the project is dead.

I'll try to get some python people to look at this bug for the future I can just encourage everybody to switch to another mixer application such as pavucontrol.

Comment 31 Joel Uckelman 2011-03-12 19:24:14 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Clicked on the mixer icon in the system tray.

Comment 32 Jeremy Baudoin 2011-03-13 04:08:37 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
unmute volume

Comment 33 Jeremy Baudoin 2011-03-13 07:09:04 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
unmute volume

Comment 34 arven979 2011-03-13 15:24:29 UTC
(In reply to comment #30)
> (In reply to comment #29)
> > Any chance for fixing this? 
> 
> Frankly speaking not, gmixer was recently orphaned in Fedora because the
> upstream developers have disappeared. The last commit was two years ago, so the
> project is dead.
> 
> I'll try to get some python people to look at this bug for the future I can
> just encourage everybody to switch to another mixer application such as
> pavucontrol.

I cannot use pulseaudio because my computer is rather old and it just doesn't work fine. Ever since I installed Fedora a few weeks ago, I've been trying to get pulseaudio to work, but I couldn't. With alsa, everything works just fine, only volume control applet in the panel is missing. Installing gmixer solved this and the speaker icon appeared and everything worked just fine until one of the recent updates. Shame.

Comment 35 dereed 2011-03-15 21:26:05 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Clicked speaker icon in the tray
2.
3.


Comment
-----
New Fedora installation.
Happened just after I restarted (after installing all the available updates).

Comment 36 kais 2011-03-15 21:56:31 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.gtalk

Comment 37 Mark Einon 2011-03-16 11:13:53 UTC
Hullo,

I've taken a look at the source rpm package for gmixer (gmixer-1.3-19.fc14.src.rpm) and this crash was introduced by the trayicon_transparency.patch
from the 1.3-19 version. 

If you're having issues with this, I'd suggest installing the previous gmixer-1.2-17.fc14 package which shouldn't have this patch applied.

Comment 38 arven979 2011-03-16 12:01:24 UTC
(In reply to comment #37)
> Hullo,
> 
> I've taken a look at the source rpm package for gmixer
> (gmixer-1.3-19.fc14.src.rpm) and this crash was introduced by the
> trayicon_transparency.patch
> from the 1.3-19 version. 
> 
> If you're having issues with this, I'd suggest installing the previous
> gmixer-1.2-17.fc14 package which shouldn't have this patch applied.

Indeed, no crash problems with the earlier version. The upgrade of gmixer package seems to have caused all those issues.

gmixer-1.2.17.fc14.i686 can be downloaded from here:

http://download.fedora.redhat.com/pub/fedora/linux/releases/14/Everything/i386/os/Packages/gmixer-1.3-17.fc14.i686.rpm

$ su -
# yum remove gmixer
# rpm -ivh gmixer-1.3-17.fc14.i686.rpm

Comment 39 Jeremy Baudoin 2011-03-16 12:49:55 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
bbooyu

Comment 40 Mark Einon 2011-03-16 12:58:54 UTC
(In reply to comment #38)
> (In reply to comment #37)
> > Hullo,
> > 
> > I've taken a look at the source rpm package for gmixer
> > (gmixer-1.3-19.fc14.src.rpm) and this crash was introduced by the
> > trayicon_transparency.patch
> > from the 1.3-19 version. 
> > 
> > If you're having issues with this, I'd suggest installing the previous
> > gmixer-1.2-17.fc14 package which shouldn't have this patch applied.
> 
> Indeed, no crash problems with the earlier version. The upgrade of gmixer
> package seems to have caused all those issues.
> 
> gmixer-1.2.17.fc14.i686 can be downloaded from here:
> 
> http://download.fedora.redhat.com/pub/fedora/linux/releases/14/Everything/i386/os/Packages/gmixer-1.3-17.fc14.i686.rpm
> 
> $ su -
> # yum remove gmixer
> # rpm -ivh gmixer-1.3-17.fc14.i686.rpm

Or even easier - 

     # sudo yum downgrade gmixer

Comment 41 Jeremy Baudoin 2011-03-16 15:29:57 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
bbooyu

Comment 42 Jeremy Baudoin 2011-03-16 16:26:40 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
bbooyu

Comment 43 Jeremy Baudoin 2011-03-16 18:47:26 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
on startup

Comment 44 Jeremy Baudoin 2011-03-16 19:29:23 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.
2.
3.
on startup

Comment 45 ashley pritchard 2011-03-17 16:25:55 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I just logged in 
2.
3.

Comment 46 ashley pritchard 2011-03-18 02:14:13 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I just logged in 
2.
3.

Comment 47 arven979 2011-03-18 11:35:24 UTC
It seems the problem is fixable - if it didn't exist in gmixer-1.3-17.fc14 package, and appeared in the updated gmixer-1.3-19.fc14, this update should be nullified.

Why so much time?

Comment 48 Flos Lonicerae 2011-03-19 12:43:01 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
click gmixer trayicon on my XFCE of FC14

Comment 49 leigh scott 2011-03-19 15:14:05 UTC
(In reply to comment #47)
> It seems the problem is fixable - if it didn't exist in gmixer-1.3-17.fc14
> package, and appeared in the updated gmixer-1.3-19.fc14, this update should be
> nullified.
> 
> Why so much time?


I orphaned gmixer as upstream is dead and I got sick of my mailbox getting spammed with gmixer bugreports.

https://admin.fedoraproject.org/pkgdb/acls/name/gmixer

Comment 50 Joel Uckelman 2011-03-19 15:43:47 UTC
If gmixer is orphaned, what should we use instead for a one-click tray volume control?

Comment 51 arven979 2011-03-19 19:40:31 UTC
This isn't spam. Fedora users that have installed a working Fedora package via Fedora repository are experiencing bugs and crash reports after the update. :-/

Comment 52 enzo 2011-03-20 09:46:33 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. after a click on th e applet panel the program crashed
2.
3.

Comment 53 Raphael Groner 2011-03-20 12:56:23 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I do not know what happened just after login to Xfce.
2.
3.

Comment 54 Riccardo Angelino 2011-03-21 19:49:57 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. I booted fedora LXDE;
2. After I have finished the session;
3. After which appeared three icons of gmixer in application panel;
4. I clicked one of the three icons and crashed gmixer

Comment 55 Riccardo Angelino 2011-03-21 19:56:46 UTC
Created attachment 486679 [details]
three icons

This is how the icons appear.

Comment 56 Riccardo Angelino 2011-03-21 20:03:01 UTC
Created attachment 486680 [details]
window

It also appears that this window does not remove.

Comment 57 Bob Reed 2011-03-22 06:09:07 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Booted up pc
2. clicked the gmixer icon next to the sound voulume icon
3. crash

Comment 58 Raphael Groner 2011-03-22 12:24:28 UTC
Maybe it would be good to have an yum plugin that warns at to install orphaned packages? So, it could be that unexperienced users will not install it.

Well, it makes not much sense IMHO to have orphaned packages by default in a "stable" release, as well not suggested for live images.

Other opinions?

Comment 59 Rick Foos 2011-03-22 15:16:50 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Open Gmixes control
2.No sound, and crash
3.


Comment
-----
ASRock motherboard. Both ATI and NVIdia HDMI cards.

Comment 60 Raphos 2011-03-22 20:42:07 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.I don't know
2.
3.

Comment 61 Terry Wallwork 2011-03-23 15:28:51 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. crash on changing volume
2.
3.

Comment 62 bellycat 2011-03-23 22:35:54 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. No any action
2.
3.

Comment 63 nomnex 2011-03-24 02:05:16 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. left click on the sound icon in the LXDE-14 Fedor panel
2.
3.


Comment
-----
anytime I click on the sound icon in the panel, the control windows at the upper left of the screen  (laptop). Expected window location: just over the sound icon panel (as it was in Lxde 13 Fedora)

as soon as I change the volum using control (volume up/down) it crashes randomely.

Comment 64 Samuel 2011-03-24 02:07:24 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. .
2.
3.

Comment 65 Eduardo Toledo 2011-03-24 18:04:51 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Star Gmixer
2.Crashed
3.

Comment 66 r.rohan123 2011-03-25 17:48:11 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.Clicked gmixer
2.Error report came
3.

Comment 67 jrg 2011-03-26 08:37:48 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1.click on the icon "sound speaker" on the right of clock
2.
3.

Comment 68 Flos Lonicerae 2011-03-26 16:30:43 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
click gmixer trayicon on my XFCE of FC14

Comment 69 Thomas Moschny 2011-03-27 02:24:11 UTC
Created attachment 487977 [details]
proposed patch

Attempt to fix the issue. Only tested on a single monitor.

Comment 70 Thomas Moschny 2011-03-28 21:15:06 UTC
Created attachment 488274 [details]
proposed patch

Update patch so it can be used in the specfile. Apply with

Patch7:         gmixer-1.3-eventbox.patch

%patch7 -p1 -b .eventbox

Comment 71 Fedora Update System 2011-03-28 21:49:20 UTC
gmixer-1.3-20.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/gmixer-1.3-20.fc14

Comment 72 Christoph Wickert 2011-03-28 21:50:42 UTC
Ok people, the fix you all have been waiting for is here. Go and get the update tested at https://admin.fedoraproject.org/updates/gmixer-1.3-20.fc14

Comment 73 Raphael Groner 2011-03-29 17:15:57 UTC
Thanks for your effort, guys.

(In reply to comment #70)
Just a short question / suggestion: Why don't you merge both patches trayicon_transparency.patch and gmixer-1.3-eventbox.patch into only one single patch? It would be no problem due to usage of git.
Reason for my thought: After I have analyzed the git backlog, I can come to the conclusion that the transparency patch has broken gmixer cause of a changed interface and - as already known - makes the code not working with the referenced but not any more existing eventbox usage later in the code. Therefore, the eventbox patch makes only sense in combination with the first mentioned incomplete patch. If you ask me, the both patches should go together and be sumed into one single patch.
Okay, the eventbox patch is not in git (currently). The dead git would be an argument against that idea.

Comment 74 enzo 2011-03-29 17:38:00 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. jast call the applet  and it crashed
2.
3.

Comment 75 Raphael Groner 2011-03-29 17:45:10 UTC
(In reply to comment #74)
enzo, please read comment #72 ;)

Comment 76 Fedora Update System 2011-03-29 19:53:12 UTC
Package gmixer-1.3-20.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gmixer-1.3-20.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/gmixer-1.3-20.fc14
then log in and leave karma (feedback).

Comment 77 marco 2011-03-30 22:30:01 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Can't tell. I'd like to give any details buti only happened once
2.
3.

Comment 78 Christoph Wickert 2011-03-30 23:00:56 UTC
Come on people: 32 people are affected by this bug and nobody is able to test the update and provide feedback at
https://admin.fedoraproject.org/updates/gmixer-1.3-20.fc14 ?

Comment 79 Rick Foos 2011-03-31 00:44:59 UTC
Tested update, still an index problem with NVidia HDMI Audio.

Two Gmixer icoins on panel. One for onboard analog ac97, one for hdmi from graphics cards.
Nvidia card installed.

Steps to reproduce:
1. Open Gmixer for HDMI
Devices HDA ATI SB, HDA NVIDIA

2. Select Nvidia Device
3. Enable IEC598  Switches
4. Gmixer Crash Report below.

Afterwards, gmixer hdmi doesn't display volume controls, but preferences can be opened.

----
gmixer:822:_update_tray:IndexError: list index out of range

Traceback (most recent call last):
  File "/usr/bin/gmixer", line 712, in _refresh_volume
    self._update_tray()
  File "/usr/bin/gmixer", line 822, in _update_tray
    vol = float(list(self._current_mixer.get_volume(track))[0])
IndexError: list index out of range

Local variables in innermost frame:
track: <__main__.GstAlsaMixerTrack object at 0x14bef50 (GstAlsaMixerTrack at 0x15f5280)>
max: 0.0
self: <GMixer object at 0x14a13c0 (GObject at 0x14f64e0)>

Comment 80 barry 2011-04-01 23:23:54 UTC
Package: gmixer-1.3-19.fc14
Architecture: x86_64
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. no idea. was not at home when it happened, but when left the house was running a internet radio station - wjjf
2.
3.

Comment 81 r.rohan123 2011-04-06 16:40:52 UTC
Package: gmixer-1.3-19.fc14
Architecture: i686
OS Release: Fedora release 14 (Laughlin)


How to reproduce
-----
1. Opened Gmixer
2. Crash message came
3.

Comment 82 Fedora Update System 2011-04-06 22:31:44 UTC
gmixer-1.3-20.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 83 Christoph Wickert 2011-04-06 22:47:37 UTC
(In reply to comment #79)
> Tested update, still an index problem with NVidia HDMI Audio.

This is a different issue, let's not discuss this here.

Comment 84 nomnex 2011-04-11 05:14:39 UTC
Thank you working fine now!


Note You need to log in before you can comment on or make changes to this bug.