Bug 678877 - AttributeError: 'NoneType' object has no attribute 'addChild'
AttributeError: 'NoneType' object has no attribute 'addChild'
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:3c7a8877f083b0e52...
: CommonBugs
: 681047 (view as bug list)
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-02-20 10:23 EST by Sandro Mathys
Modified: 2011-03-27 00:23 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-15.22-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-16 00:06:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (268.97 KB, text/plain)
2011-02-20 10:23 EST, Sandro Mathys
no flags Details
updates to attempt on-demand scanning of containers as needed (18.98 KB, application/octet-stream)
2011-02-23 12:20 EST, David Lehman
no flags Details
patch to anaconda to attempt on-demand scanning of md containers as needed (1.75 KB, patch)
2011-02-23 12:27 EST, David Lehman
no flags Details | Diff
Attached traceback automatically from anaconda. (1.21 MB, text/plain)
2011-02-28 18:11 EST, Adam Williamson
no flags Details
Attached traceback automatically from anaconda. (291.12 KB, text/plain)
2011-03-27 00:23 EDT, Don Church
no flags Details

  None (edit)
Description Sandro Mathys 2011-02-20 10:23:17 EST
The following was filed automatically by anaconda:
anaconda 15.20 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 231, in __init__
    parent.addChild()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 458, in __init__
    Device.__init__(self, name, parents=parents)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 2577, in __init__
    parents=parents, sysfsPath=sysfsPath)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 863, in addUdevDiskDevice
    sysfsPath=sysfs_path, **kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 983, in addUdevDevice
    device = self.addUdevDiskDevice(info)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1756, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1714, in populate
    self._populate()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 434, in reset
    self.devicetree.populate()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 103, in storageInitialize
    storage.reset()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1257, in nextClicked
    self.anaconda.dispatch.gotoNext()
AttributeError: 'NoneType' object has no attribute 'addChild'
Comment 1 Sandro Mathys 2011-02-20 10:23:23 EST
Created attachment 479773 [details]
Attached traceback automatically from anaconda.
Comment 2 David Lehman 2011-02-23 12:20:26 EST
Created attachment 480535 [details]
updates to attempt on-demand scanning of containers as needed

Please try out this updates image and let me know if it helps. Here's some info if you need it:

https://fedoraproject.org/wiki/Anaconda/Updates#Updates_from_the_Network
Comment 3 David Lehman 2011-02-23 12:27:24 EST
Created attachment 480537 [details]
patch to anaconda to attempt on-demand scanning of md containers as needed

I notice you're doing a live install, so updates won't work.

To apply this patch, run this command as root on your livecd before launching liveinst (assuming you've saved it in /tmp):

 cd /usr/lib64/python2.7/site-packages && patch -p1 < /tmp/20110223-md-fwraid-scan-order-678877.patch
Comment 4 David Lehman 2011-02-23 12:29:10 EST
This may prevent any successful storage scan on intel fwraid systems, so proposing as a beta blocker.
Comment 5 Sandro Mathys 2011-02-24 13:24:32 EST
I can confirm this fix resolves the issue. Now I see #680226 - can you please have an eye on that one to be sure your fix is not causing the new issue by accident? Just to be sure.
Comment 6 Adam Williamson 2011-02-28 18:11:17 EST
Created attachment 481468 [details]
Attached traceback automatically from anaconda.
Comment 7 Adam Williamson 2011-02-28 18:13:12 EST
I'm hitting something similar to this. Interestingly, if I just select 'basic storage devices' it gets reported as a different bug, https://bugzilla.redhat.com/show_bug.cgi?id=681047 ; if I select 'specialized storage devices' and leave the messed-up 'drives' which appear to represent the partitions on the RAID array unselected, and select only the USB key I also have plugged in as an install target, anaconda still crashes, and the crash is marked as a dupe of this bug (see comment #6).
Comment 8 Adam Williamson 2011-02-28 18:26:36 EST
*** Bug 681047 has been marked as a duplicate of this bug. ***
Comment 9 Adam Williamson 2011-02-28 18:27:01 EST
we should document this for Alpha, given the breadth of impact.
Comment 10 James Laska 2011-03-01 07:21:51 EST
(In reply to comment #9)
> we should document this for Alpha, given the breadth of impact.

Adam, have you had any luck with the proposed patch in comment#4?
Comment 11 Adam Williamson 2011-03-01 11:47:39 EST
Same experience as Sandro: it causes or exposes #680226 instead.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 12 David Lehman 2011-03-03 10:50:06 EST
Patches that fix all known firmware RAID issues for F15 are available in bug 681608 for those doing live installs. For those doing non-live installs, just ask and I'll be happy to provide an updates image for you to test with.
Comment 13 David Lehman 2011-03-09 14:07:44 EST
Fixed for Fedora 15 in anaconda-15.22-1.
Comment 14 Fedora Update System 2011-03-09 16:55:16 EST
anaconda-15.22-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.22-1.fc15
Comment 15 James Laska 2011-03-11 14:40:40 EST
Discussed at 2011-03-11 blocker review meeting.  This issue is fixed and available for testing in anaconda-15.22-1.  The issue has been accepted as a beta blocker.
Comment 16 Fedora Update System 2011-03-16 00:05:55 EDT
anaconda-15.22-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Don Church 2011-03-27 00:23:31 EDT
Created attachment 487984 [details]
Attached traceback automatically from anaconda.

Note You need to log in before you can comment on or make changes to this bug.