Bug 678950 - Cannot locate object method 'can_handle' when convert Red Hat desktop
Summary: Cannot locate object method 'can_handle' when convert Red Hat desktop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: virt-v2v
Version: 6.1
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Matthew Booth
QA Contact: Virtualization Bugs
URL:
Whiteboard:
: 718088 (view as bug list)
Depends On:
Blocks: 718088
TreeView+ depends on / blocked
 
Reported: 2011-02-21 03:45 UTC by Rita Wu
Modified: 2015-09-28 02:26 UTC (History)
6 users (show)

Fixed In Version: virt-v2v-0.7.1-4.el6
Doc Type: Bug Fix
Doc Text:
Conversion of a Red Hat Enterprise Linux Desktop virtual machine failed with the following error: Can't locate object method "can_handle" via package "Sys::VirtV2V::Converter::RedHat" at /usr/share/perl5/vendor_perl/Sys/VirtV2V/Converter.pm line 121. This issue has been resolved and conversion should now complete successfully.
Clone Of:
Environment:
Last Closed: 2011-05-19 13:54:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
LIBGUESTFS_TRACE=1 during conversion (119.56 KB, text/plain)
2011-02-21 03:45 UTC, Rita Wu
no flags Details
virt-inspector.log (401.40 KB, text/plain)
2011-02-21 03:45 UTC, Rita Wu
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:0650 normal SHIPPED_LIVE virt-v2v and augeas bug fix update 2011-07-01 15:27:50 UTC

Description Rita Wu 2011-02-21 03:45:08 UTC
Created attachment 479810 [details]
LIBGUESTFS_TRACE=1 during conversion

Description of problem:
Cannot locate object method 'can_handle' when convert Red Hat desktop 

Version-Release number of selected component (if applicable):
virt-v2v-0.7.1-3.el6.x86_64
libguestfs-1.7.17-12.el6.x86_64
libguestfs-*-1.7.17-12.el6.x86_64
augeas-libs-0.7.2-4.el6.x86_64



How reproducible:
100%

Steps to Reproduce:
1. Convert a Red Hat Desktop Release VM: 
 # virt-v2v -ic esx://10.66.73.xxx/?no_verify=1 -o rhev -osd 10.66.90.xxx:/vol/v2vrwu2/esx_export ESX3.5-RHEL4.8-32b
ESX3.5-RHEL4.8-32b_ESX3.5-RHEL4.8-32b:  23% [=====           *       ]ETA  17:41ESX3.5-RHEL4.8-32b_ESX3.5-RHEL4.8-32b: 100% [========================]D 1h44m56s
Can't locate object method "can_handle" via package "Sys::VirtV2V::Converter::RedHat" at /usr/share/perl5/vendor_perl/Sys/VirtV2V/Converter.pm line 121.


  
Actual results:
Cannot convert a Red Hat Desktop Release VM

Expected results:
Convert successfully.

Additional info:
#LIBGUESTFS_TRACE=1 virt-inspector --perl ESX3.5-RHEL4.8-32b
...
libguestfs: trace: cat = "Red Hat Desktop release 4 (Nahant Update 8)
...

Comment 1 Rita Wu 2011-02-21 03:45:49 UTC
Created attachment 479811 [details]
virt-inspector.log

Comment 3 Matthew Booth 2011-02-22 11:16:12 UTC
This is already fixed upstream.

Comment 5 Huang Wenlong 2011-03-02 08:49:58 UTC
verify this bug in rhel6 with :
virt-v2v-0.7.1-4.el6.x86_64

libguestfs-1.7.17-14.el6.x86_64

libguestfs-*-1.7.17-14.el6.x86_64

libvirt-0.8.7-8.el6.x86_64

febootstrap-2.11-6.el6.x86_64

hivex-1.2.4-3.el6.x86_64

libguestfs-winsupport-1.0-5.el6.x86_64

augeas-libs-0.7.2-4.el6.x86_64

virtio-win-1.1.16-1.el6.noarch



Test step:

#virt-v2v -ic esx://10.66.73.244/?no_verify=1   -op sdb1-rhel6  -b breth0 ESX3.5-Desktop4.8-32b
ESX3.5-RHEL4.8-32b_ESX3.5-RHEL4.8-32b: 100% [=====================================================================================================]D 0h45m12s
virt-v2v: WARNING: Unable to convert this guest operating system. Its storage will be transfered and a domain created for it, but it may not operate correctly without manual reconfiguration. The domain will present all storage devices as ide, all network interfaces as rtl8139, and the host as x86_64.
virt-v2v: ESX3.5-Desktop4.8-32b configured without virtio drivers

Comment 9 Laura Bailey 2011-04-28 04:02:07 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Conversion of a Red Hat Enterprise Linux Desktop virtual machine failed with the following error:

   Can't locate object method "can_handle" via package
   "Sys::VirtV2V::Converter::RedHat" at
   /usr/share/perl5/vendor_perl/Sys/VirtV2V/Converter.pm line 121.

This issue has been resolved and conversion should now complete successfully.

Comment 11 errata-xmlrpc 2011-05-19 13:54:23 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0650.html

Comment 12 Matthew Booth 2011-07-01 16:27:27 UTC
*** Bug 718088 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.