Bug 679023 - livecd-iso-to-disk --livedir broken
livecd-iso-to-disk --livedir broken
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
15
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-21 05:21 EST by Jan Kratochvil
Modified: 2011-05-09 23:27 EDT (History)
6 users (show)

See Also:
Fixed In Version: livecd-tools-15.7-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-09 23:27:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix. (2.86 KB, patch)
2011-02-21 05:21 EST, Jan Kratochvil
no flags Details | Diff

  None (edit)
Description Jan Kratochvil 2011-02-21 05:21:34 EST
Created attachment 479861 [details]
Fix.

Description of problem:
Biarch_Spin has stopped building since livecd-tools-15.4-1.fc15.

Version-Release number of selected component (if applicable):
livecd-tools-15.5-1.fc15

How reproducible:
Always.

Steps to Reproduce:
Try to build: http://fedoraproject.org/wiki/Biarch_Spin
or:
# gzip -1 </dev/sdXb|wc -c
4683762
# echo|time livecd-iso-to-disk --format --livedir foobar some.iso /dev/sdXb
[...]
# gzip -1 </dev/sdXb|wc -c

Actual results:
0:21.95elapsed
18394173

Expected results:
more time elapsed
more than 18MB copied from the 800MB ISO file

Additional info:
It considers the installation as "netinst" as it cannot find the right files.

[Fedora-livecd-list] [patch] Regression livecd-iso-to-disk --livedir
http://lists.fedoraproject.org/pipermail/livecd/2011-February/006651.html
->
There exists no `livecd-creator --livedir' so on the source media the directory is always called `LiveOS'.
Comment 1 Fedora Update System 2011-03-29 12:42:06 EDT
livecd-tools-15.6-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/livecd-tools-15.6-1.fc15
Comment 2 Fedora Update System 2011-03-29 22:33:55 EDT
Package livecd-tools-15.6-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing livecd-tools-15.6-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/livecd-tools-15.6-1.fc15
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2011-05-06 14:15:25 EDT
livecd-tools-15.7-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/livecd-tools-15.7-1.fc15
Comment 4 Fedora Update System 2011-05-09 23:27:07 EDT
livecd-tools-15.7-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.