Bug 679056 - [abrt] yumex-3.0.1-2.fc15: views.py:1247:populate:TypeError: value is of wrong type for this column
Summary: [abrt] yumex-3.0.1-2.fc15: views.py:1247:populate:TypeError: value is of wron...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: yumex
Version: rawhide
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Lauridsen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:d72b9d0c
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-21 13:00 UTC by Stephen
Modified: 2011-04-07 18:52 UTC (History)
5 users (show)

Fixed In Version: yumex-3.0.2-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-05 21:34:36 UTC


Attachments (Terms of Use)
File: backtrace (1.86 KB, text/plain)
2011-02-21 13:00 UTC, Stephen
no flags Details

Description Stephen 2011-02-21 13:00:53 UTC
abrt version: 1.1.17
architecture: x86_64
cmdline: /usr/bin/python /usr/share/yumex/yumex.pyc
component: yumex
executable: /usr/share/yumex/yumex.pyc
kernel: 2.6.38-0.rc5.git5.1.fc15.x86_64.debug
package: yumex-3.0.1-2.fc15
reason: views.py:1247:populate:TypeError: value is of wrong type for this column
release: Fedora release 16 (Rawhide)
time: 1298292897
uid: 500

backtrace
-----
views.py:1247:populate:TypeError: value is of wrong type for this column

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/yumexgui/gui.py", line 420, in on_button_clicked
    self.notebook.set_page(key) # set the new notebook page
  File "/usr/lib/python2.7/site-packages/yumexgui/gui.py", line 478, in set_page
    callback()
  File "/usr/lib/python2.7/site-packages/yumexgui/__init__.py", line 913, in setup_history
    self.history.populate(data)
  File "/usr/lib/python2.7/site-packages/yumexgui/views.py", line 1247, in populate
    self.model.append([id, user, dt, action, alt])
TypeError: value is of wrong type for this column

Local variables in innermost frame:
self: <yumexgui.views.YumexHistoryView instance at 0x1b09200>
dt: '2011-02-21 07:46'
user: 'Steve ... <spoffley>'
action: u'Install'
alt: 3
data: [[1211, 'Steve ... <spoffley>', '2011-02-21 07:46', u'Install', 3], [1210, 'Steve ... <spoffley>', '2011-02-21 07:42', u'Erase', 1], [1209, 'root <root>', '2011-02-20 20:54', u'I, U', 339], [1208, 'Steve ... <spoffley>', '2011-02-14 08:04', u'I, O, U', 43], [1207, 'Steve ... <spoffley>', '2011-02-13 18:33', u'E, I, O, U', 2866], [1206, u'System <unset>', '2011-02-13 16:17', u'Update', 1], [1205, u'System <unset>', '2011-02-13 16:15', u'Update', 1], [1204, 'Steve ... <spoffley>', '2011-02-13 15:41', u'Update', 102], [1203, 'Steve ... <spoffley>', '2011-02-03 19:54', u'Update', 42], [1202, 'Steve ... <spoffley>', '2011-01-29 17:29', u'Update', 7], [1201, 'Steve ... <spoffley>', '2011-01-26 13:31', u'Update', 4], [1200, 'Steve ... <spoffley>', '2011-01-26 12:41', u'Update', 10], [1199, 'Steve ... <spoffley>', '2011-01-26 12:14', u'E, I, U', 7], [1198, 'Steve ... <spoffley>', '2011-01-26 12:08', u'Update', 3], [1197, 'Steve ... <spoffley>', '2011-01-26 12:01', u'Update', 11], [1196, 'Steve ... <spoffley>', '2011-01-26 11:57', u'Update', 10]]
id: 1211

How to reproduce
-----
1. Clicked on the History button
2.
3.

Comment 1 Stephen 2011-02-21 13:00:56 UTC
Created attachment 479907 [details]
File: backtrace

Comment 2 dominique 2011-03-02 06:15:08 UTC
Package: yumex-3.0.1-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
When I want looking the history in yumex, I have this abrt error.

Comment 3 Tim Lauridsen 2011-03-03 16:48:04 UTC
Should be fixed in the pre-release packages located here

http://repos.fedorapeople.org/repos/timlau/yumex/

Comment 4 dominique 2011-03-03 17:13:02 UTC
For me and my F15, package "yumex-3.0.2-0.1.git20110302.fc15.noarch.rpm" solve problem.
Thank Tim...

Comment 5 martux 2011-03-13 00:46:44 UTC
Package: yumex-3.0.1-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1. installed yumex
2. choosed history
3. got the crash


Comment
-----
may the reason is, that i installed libreoffice not via package-kit but via download and  just after this i created a own repo with the rpms of my libreoffice-download. at the end i installed yumex and got the crash mentioned above...
hope that helps...

Comment 6 Tim Lauridsen 2011-03-13 08:21:20 UTC
@martux, please test the packages in Comment 3, to see if solves the issue

Comment 7 Viess 2011-03-21 14:51:14 UTC
Package: yumex-3.0.1-2.fc15
Architecture: i686
OS Release: Fedora release 16 (Rawhide)


How to reproduce
-----
1. clicked "history" button @ yumex
2.
3.

Comment 8 Greg` 2011-03-24 07:05:53 UTC
Package: yumex-3.0.1-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)


How to reproduce
-----
1.i was clicked on the History Button and crashed 
2.
3.

Comment 9 Greg` 2011-03-24 07:10:06 UTC
(In reply to comment #8)
> Package: yumex-3.0.1-2.fc15
> Architecture: x86_64
> OS Release: Fedora release 15 (Lovelock)
> 
> 
> How to reproduce
> -----
> 1.i was clicked on the History Button and crashed 
> 2.
> 3.
just noticed  ' comment 3 ' will test it

Comment 10 Fedora Update System 2011-03-30 07:55:12 UTC
yumex-3.0.2-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/yumex-3.0.2-1.fc15

Comment 11 Fedora Update System 2011-03-30 07:55:38 UTC
yumex-3.0.2-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/yumex-3.0.2-1.fc14

Comment 12 Fedora Update System 2011-03-30 20:04:41 UTC
Package yumex-3.0.2-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yumex-3.0.2-1.fc14'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/yumex-3.0.2-1.fc14
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2011-04-05 21:34:17 UTC
yumex-3.0.2-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2011-04-07 18:52:16 UTC
yumex-3.0.2-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.