Bug 679080 - fsck.gfs2: segfault in pass1b
Summary: fsck.gfs2: segfault in pass1b
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster
Version: 6.1
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: ---
Assignee: Robert Peterson
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On: 679076
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-21 14:19 UTC by Robert Peterson
Modified: 2011-12-06 14:50 UTC (History)
11 users (show)

Fixed In Version: cluster-3.0.12.1-2.el6
Doc Type: Bug Fix
Doc Text:
When fsck.gfs2 resolves duplicate block references, if all block references are found to be invalid (no valid references are found), its reference list becomes empty. Some code in pass1b improperly tried to access references on the empty list. As a result, fsck.gfs2 would end abnormally with a segmentation fault. Code was added to pass1b to check for the list being empty. As a result, the segmentation fault no longer occurs and fsck.gfs2 proceeds normally.
Clone Of: 679076
Environment:
Last Closed: 2011-12-06 14:50:49 UTC


Attachments (Terms of Use)
Final patch (906 bytes, patch)
2011-06-03 12:55 UTC, Robert Peterson
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1516 normal SHIPPED_LIVE cluster and gfs2-utils bug fix update 2011-12-06 00:51:09 UTC

Description Robert Peterson 2011-02-21 14:19:55 UTC
+++ This bug was initially created as a clone of Bug #679076 +++
Cloned for a RHEL6 crosswrite fix.

Description of problem:
While recently analyzing a customer's gfs2 metadata, I ran
fsck.gfs2 and it segfaulted in pass1b.  I tracked down the
problem, and this bug is to track the problem and its fix.

Version-Release number of selected component (if applicable):
RHEL57

How reproducible:
Unknown

Steps to Reproduce:
1. Restore customer metadata
2. fsck.gfs2 -y /dev/device
3.
  
Actual results:
Segfault in pass1b

Expected results:
fsck.gfs2 should run to completion.

Additional info:
Patch available

--- Additional comment from rpeterso@redhat.com on 2011-02-21 09:15:25 EST ---

Created attachment 479925 [details]
Patch to fix the problem

The problem occurred when there were duplicate block
references in a dinode but all references in the duplicate
list are eventually deleted due to other corruption.
The fix is an additional check whether the list is empty.

--- Additional comment from rpeterso@redhat.com on 2011-02-21 09:16:28 EST ---

Requesting ack flags for 5.7.

Comment 1 Robert Peterson 2011-02-22 22:40:09 UTC
I pushed the patch to the master branch of the gfs2-util
git repo.  I guess I'll have to wait to push it into the
RHEL6 branch of cluster.git until 6.1 branches from RHEL6,
unless management wants to squeeze it in.

Comment 2 Steve Whitehouse 2011-05-06 14:37:14 UTC
Can we get this into the rhel6 branch yet?

Comment 3 Robert Peterson 2011-05-06 15:14:25 UTC
RHEL61 still has not branched from RHEL6, so no.  I'll bug
Fabio when he's back from pto or Lon when he's back from Summit.

Comment 4 Robert Peterson 2011-06-03 12:55:35 UTC
Created attachment 502805 [details]
Final patch

This is the patch I pushed to the cluster.git repo for the
RHEL6 branch.

Comment 5 Robert Peterson 2011-06-03 12:57:01 UTC
Since the RHEL6 branch is now open for business, I pushed the
patch to it for inclusion into 6.2.  I tested it on system
gfs-i24c-01.  Changing status to POST until it gets built.

Comment 8 Robert Peterson 2011-10-27 13:49:57 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
When fsck.gfs2 resolves duplicate block references, if all block references are found to be invalid (no valid references are found), its reference list becomes empty.
Some code in pass1b improperly tried to access references on the empty list. As a result, fsck.gfs2 would end abnormally with a segmentation fault. Code was added to pass1b to check for the list being empty.  As a result, the segmentation fault no longer occurs and fsck.gfs2 proceeds normally.

Comment 9 Justin Payne 2011-11-08 17:10:37 UTC
Verified SanityOnly in cluster-3.0.12.1-23.el6

https://brewweb.devel.redhat.com/buildinfo?buildID=181570

Comment 10 errata-xmlrpc 2011-12-06 14:50:49 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1516.html


Note You need to log in before you can comment on or make changes to this bug.