Bug 679107 - TypeError: argument 2 to map() must support iteration
Summary: TypeError: argument 2 to map() must support iteration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 15
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: anaconda_trace_hash:2b36847566ccf6509...
Depends On:
Blocks: F15Alpha, F15AlphaBlocker
TreeView+ depends on / blocked
 
Reported: 2011-02-21 15:56 UTC by James Laska
Modified: 2013-09-02 06:53 UTC (History)
6 users (show)

Fixed In Version: anaconda-15.20.1-1.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-02-25 03:50:27 UTC


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (1.81 MB, text/plain)
2011-02-21 15:56 UTC, James Laska
no flags Details
Attached traceback automatically from anaconda. (554.25 KB, text/plain)
2011-02-21 17:06 UTC, James Laska
no flags Details
Attached traceback automatically from anaconda. (502.03 KB, text/plain)
2011-02-21 18:00 UTC, Dennis Gilmore
no flags Details

Description James Laska 2011-02-21 15:56:50 UTC
The following was filed automatically by anaconda:
anaconda 15.20 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/installclass.py", line 161, in setGroupSelection
    map(lambda x: anaconda.backend.selectGroup(x), grps)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/installclasses/fedora.py", line 78, in setGroupSelection
    BaseInstallClass.setGroupSelection(self, anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/backend.py", line 215, in doBasePackageSelect
    anaconda.instClass.setGroupSelection(anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1346, in setScreen
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1258, in nextClicked
    self.setScreen ()
TypeError: argument 2 to map() must support iteration

Comment 1 James Laska 2011-02-21 15:56:54 UTC
Created attachment 479944 [details]
Attached traceback automatically from anaconda.

Comment 2 James Laska 2011-02-21 15:57:52 UTC
I hit this bug after manually patching for bug#672030, and continuing the install.

Comment 3 James Laska 2011-02-21 17:06:13 UTC
Created attachment 479958 [details]
Attached traceback automatically from anaconda.

Comment 4 James Laska 2011-02-21 17:22:07 UTC
Proposing as an Alpha blocker as this impacts the following alpha criteria [1]:

    "The installer must boot (if appropriate) and run on all 
     primary architectures from default live image, DVD, and 
     boot.iso install media"

In my testing, this appears to happen consistently.  I'm not aware of any workarounds at this time.  I suspect this will impact all live install users, so I am proposing it as a blocker.

[1] https://fedoraproject.org/wiki/Fedora_15_Alpha_Release_Criteria

Comment 5 Dennis Gilmore 2011-02-21 18:00:00 UTC
Created attachment 479973 [details]
Attached traceback automatically from anaconda.

Comment 6 Dennis Gilmore 2011-02-21 18:01:30 UTC
I was able to repoduce.

Comment 7 James Laska 2011-02-21 19:19:14 UTC
Discussed with dgilmore and clumens on IRC.  Marking as an AcceptedBlocker for F15Alpha

Comment 8 Fedora Update System 2011-02-21 19:35:09 UTC
anaconda-15.20.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.20.1-1.fc15

Comment 9 Fedora Update System 2011-02-21 20:38:32 UTC
anaconda-15.20.1-1.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-15.20.1-1.fc15

Comment 10 James Laska 2011-02-22 13:44:06 UTC
Confirmed fix with anaconda-15.20.1-1.fc15 (RC1)

Comment 11 Fedora Update System 2011-02-25 03:50:09 UTC
anaconda-15.20.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.