Bug 67916 - ntp config is missing appropriate restrict entry
ntp config is missing appropriate restrict entry
Status: CLOSED DUPLICATE of bug 70557
Product: Red Hat Linux
Classification: Retired
Component: dateconfig (Show other bugs)
7.3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-04 06:12 EDT by yves
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-01 14:50:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yves 2002-07-04 06:12:00 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020606

Description of problem:
When the NTP option is checked in dateconfig's GUI, and a server is entered, the
tool appropriately adds the "server" entry for that given hostname, but fails to
add a "restrict" entry for that same hostname.

Given the default config that comes with the latest package for NTP, which
includes a "restrict default ignore", a "restrict" definitely needs to be added
for the synchronization to occur.

In it's current state, dateconfig fails to successfully configure the specified
NTP server.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run dateconfig
2. Enter appropriate settings and OK it
3. Check /etc/ntp.conf... no "restrict" entry for the specified server


Actual Results:  Either by looking at the logfile, or doing a "ntpdc localhost"
followed by a "peers" command, or finally by running "ntpd -ddd", it's very
clear, especially in the latter, that ntpd is dropping the response due to ACL
restrictions

Expected Results:  ntpd should have accepted the repsonse from the NTP server
and start synching itself to that server

Additional info:
Comment 1 Miloslav Trmac 2002-07-06 20:10:28 EDT
Happens here too
Comment 2 Brent Fox 2002-08-01 14:50:33 EDT
Please try redhat-config-date-1.4-7 out of Rawhide
Comment 3 Brent Fox 2002-10-25 11:58:10 EDT

*** This bug has been marked as a duplicate of 70557 ***

Note You need to log in before you can comment on or make changes to this bug.