Bug 679165 - --passphrase parameter not working as documented
--passphrase parameter not working as documented
Status: CLOSED DUPLICATE of bug 679166
Product: Fedora
Classification: Fedora
Component: pykickstart (Show other bugs)
14
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-21 14:24 EST by tsukebumi
Modified: 2011-02-21 16:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-21 16:46:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description tsukebumi 2011-02-21 14:24:10 EST
Description of problem:
Documentation for kickstart configuration for partitions says there is a --passphrase parameter to specify each partition's passphrase.
However after installation all partitions are mounted with the same passphrase as if it was a global default

Version-Release number of selected component (if applicable):
pykickstart 1.77-2
anaconda 13.22-1

How reproducible:

always

Steps to Reproduce:
1. Create a kickstart configuration file with a set of partitions where at least two are encrypted and define a different passphrase
2. make an unattended installation with said kickstart

  
Actual results:
At boot, there is a password prompt for mounting a partition. If entered correctly, all partitions are mounted and boot process continiues.

Expected results:
It should be needed to enter all passphrases in order to continue.


Additional info:
Comment 1 Chris Lumens 2011-02-21 16:46:59 EST

*** This bug has been marked as a duplicate of bug 679166 ***

Note You need to log in before you can comment on or make changes to this bug.