Bug 679180 - logging.properties not listed as a config file in the rpm
logging.properties not listed as a config file in the rpm
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: java-1.6.0-openjdk (Show other bugs)
5.8
Unspecified Unspecified
low Severity low
: rc
: ---
Assigned To: jiri vanek
BaseOS QE - Apps
:
Depends On: 680144
Blocks: 924828
  Show dependency treegraph
 
Reported: 2011-02-21 15:06 EST by Jason Pyeron
Modified: 2013-04-23 01:49 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 924828 (view as bug list)
Environment:
Last Closed: 2013-03-22 10:52:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch for %files section (1.41 KB, patch)
2011-02-22 17:34 EST, Jason Pyeron
no flags Details | Diff
console log showing gcc/g++ build requires issues (3.27 MB, text/plain)
2011-02-23 15:24 EST, Jason Pyeron
no flags Details
patch for %files and build requires (1.54 KB, patch)
2011-02-23 15:35 EST, Jason Pyeron
no flags Details | Diff
no build require update (1.20 KB, patch)
2011-02-24 08:10 EST, Jason Pyeron
jvanek: review+
Details | Diff

  None (edit)
Description Jason Pyeron 2011-02-21 15:06:08 EST
Description of problem:

modify the logging.properties, then update the package via normal yum process, not you chages will go away if there is a newer rpm package.

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:

logging.properties.rpmnew file created instead

Additional info:

working on a patch to the spec file
Comment 1 jiri vanek 2011-02-22 03:40:46 EST
Then logging properties should be marked as config(noreplace)

%config(noreplace) jre/lib/logging.properties
Comment 2 Jason Pyeron 2011-02-22 17:34:30 EST
Created attachment 480287 [details]
patch for %files section

also fixes a build requirement by adding BuildRequires: gcc-c++
Comment 3 jiri vanek 2011-02-23 02:59:42 EST
Why have you added this? BuildRequires: gcc-c++
There is no need for it.
Comment 4 Jason Pyeron 2011-02-23 07:59:06 EST
if you do not have it installed then the build will fail.

remove g++ and try to build.
Comment 5 jiri vanek 2011-02-23 08:31:21 EST
 gcc-c++ is always added as dependence of dependence.
Comment 6 Jason Pyeron 2011-02-23 14:23:11 EST
(In reply to comment #5)
>  gcc-c++ is always added as dependence of dependence.

Which dependency? I ask because, I must have managed to break something, if that was the case.

The build failed the first time with a g++ not found.
Comment 7 Jason Pyeron 2011-02-23 15:24:23 EST
Created attachment 480566 [details]
console log showing gcc/g++ build requires issues

As you can see gcc is a dependency for g++ but g++ is not a dependency for any package needed by the build requires or rpm-build.
Comment 8 Jason Pyeron 2011-02-23 15:35:35 EST
Created attachment 480572 [details]
patch for %files and build requires
Comment 9 jiri vanek 2011-02-24 05:20:54 EST
I still must disagree. When build is done on clean system (mock) tehn all dependencies are available. For missing gcc/g++ There must be fault on your machine. 
Please run mock build, nd you will be sure. The dependece can't be add. 


I will apply
%config(noreplace) %{_jvmdir}/%{jredir}/lib/logging.properties
into spec file asap I recieve acks.
Comment 10 Jason Pyeron 2011-02-24 08:10:21 EST
Created attachment 480752 [details]
no build require update

I am testing in mockbuild right now, if I can reproduce I will open another bug.
Comment 11 Jason Pyeron 2011-02-24 08:28:01 EST
did you even do a mock build? it is complaining wildly.
Comment 12 Jason Pyeron 2011-02-24 08:30:06 EST
I have opened bug 680144 for the build requires issues.
Comment 17 Jason Pyeron 2013-03-22 13:53:05 EDT
why? the patch was submitted over a year ago, and approved.
Comment 18 jiri vanek 2013-03-25 05:11:33 EDT
https://bugzilla.redhat.com/show_bug.cgi?id=924828

This is the clone for rhe 6.4. The  fix will bubble probably also to 5.X
Comment 19 jiri vanek 2013-03-25 13:12:59 EDT
Builds with fix of this were pushed to fedora.
if they will pass theirs usual QA, I'm for inclusion into next CPU for Rhel and for jdks 6
http://pkgs.fedoraproject.org/cgit/java-1.7.0-openjdk.git/commit/?id=89e2aea2f9880efd4ad773ef9dc566225c9ae9ef

Note You need to log in before you can comment on or make changes to this bug.