Bug 679193 - AttributeError: 'NoneType' object has no attribute 'format'
AttributeError: 'NoneType' object has no attribute 'format'
Status: CLOSED DUPLICATE of bug 672030
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-21 15:42 EST by John Reiser
Modified: 2011-02-21 16:06 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-21 16:06:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda traceback and debug info (32.00 KB, text/plain)
2011-02-21 15:42 EST, John Reiser
no flags Details
anaconda traceback and debug info (1.66 MB, text/plain)
2011-02-21 15:46 EST, John Reiser
no flags Details

  None (edit)
Description John Reiser 2011-02-21 15:42:14 EST
Created attachment 479991 [details]
anaconda traceback and debug info

Description of problem: Install from LiveCD triggers Error and traceback upon Next from editing partition properties.


Version-Release number of selected component (if applicable):
anaconda-15.20

How reproducible: every time


Steps to Reproduce:
1. boot desktop-x86_64-20110221.00.iso
2. run "xhost +" from a terminal to avoid bug #663294
3. Activities > Applications > Install to harddrive...
4. Custom configuration, Edit existing partition, mount on root '/', Format to ext4, OK
  
Actual results:Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/livecd.py", line 341, in getMinimumSizeMB
    return self.anaconda.storage.liveImage.format.size
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1027, in sanityCheck
    root.size < self.anaconda.backend.getMinimumSizeMB("/")):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 851, in getNext
    (errors, warnings) = self.storage.sanityCheck()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1253, in nextClicked
    rc = self.currentWindow.getNext ()
AttributeError: 'NoneType' object has no attribute 'format'



Expected results: no Error


Additional info:
Comment 1 John Reiser 2011-02-21 15:46:28 EST
Created attachment 479992 [details]
anaconda traceback and debug info

Oops, replace mistaken .anaconda-tb-***.swp (vi swap file) with this correct text file.
Comment 2 Chris Lumens 2011-02-21 16:06:32 EST

*** This bug has been marked as a duplicate of bug 672030 ***

Note You need to log in before you can comment on or make changes to this bug.