Bug 67930 - gnome-terminal crashing when mouse is moving inside..
gnome-terminal crashing when mouse is moving inside..
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: vte (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-04 09:19 EDT by Dams
Modified: 2008-05-01 11:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-18 21:38:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dams 2002-07-04 09:19:04 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020625

Description of problem:
gnome-terminal seems to crash when mouse move on or near an url
(http://blablabla..) in the prompt of epic.. or maybe it was the ":/" smiley

Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. gnome-terminal 
2. "screen epic nickname server" in the gnome-terminal


Actual Results:  I was messaging somebody with an url and when the mouse went
near of it gnome-terminal core-dumped.
It doesn't happen all the time.. only when

Expected Results:  no core dumped.

Additional info:

dnade@enclume ~]# gdb =gnome-terminal
GNU gdb Red Hat Linux (5.1.92-3)
Copyright 2002 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux"...(no debugging symbols found)...
(gdb) run
Starting program: /usr/bin/gnome-terminal 
(no debugging symbols found)...(no debugging symbols found)...[New Thread 1024
(LWP 19917)]

** (gnome-terminal:19917): WARNING **: Invalid multibyte sequence detected. 
Munging up 1 bytes of data.

** ERROR **: file vte.c: line 986 (vte_terminal_match_check_int): assertion
failed: (matches[j].rm_eo + coffset <= terminal->pvt->match_attributes->len)
aborting...

Program received signal SIGABRT, Aborted.
[Switching to Thread 1024 (LWP 19917)]
0x42027811 in kill () from /lib/i686/libc.so.6
(gdb) bt
#0  0x42027811 in kill () from /lib/i686/libc.so.6
#1  0x408abe6d in raise () from /lib/i686/libpthread.so.0
#2  0x42028db9 in abort () from /lib/i686/libc.so.6
#3  0x40404396 in g_logv () from /usr/lib/libglib-2.0.so.0
#4  0x404043d4 in g_log () from /usr/lib/libglib-2.0.so.0
#5  0x40451568 in vte_terminal_match_check_int () from /usr/lib/libvte.so.1
#6  0x4045d0d3 in vte_terminal_match_hilite () from /usr/lib/libvte.so.1
#7  0x4045d377 in vte_terminal_motion_notify () from /usr/lib/libvte.so.1
#8  0x40115684 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#9  0x403a14a7 in g_type_class_meta_marshal () from /usr/lib/libgobject-2.0.so.0
#10 0x403a1100 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#11 0x403b5179 in signal_emit_unlocked_R () from /usr/lib/libgobject-2.0.so.0
#12 0x403b4499 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#13 0x401570d2 in gtk_signal_emit () from /usr/lib/libgtk-x11-2.0.so.0
#14 0x401f8c53 in gtk_widget_send_expose () from /usr/lib/libgtk-x11-2.0.so.0
#15 0x40115417 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#16 0x401140e5 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#17 0x402c19b1 in gdk_add_client_message_filter () from /usr/lib/libgdk-x11-2.0.so.0
#18 0x403fbe85 in g_main_dispatch () from /usr/lib/libglib-2.0.so.0
#19 0x403fceb8 in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#20 0x403fd1cd in g_main_context_iterate () from /usr/lib/libglib-2.0.so.0
#21 0x403fd93f in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#22 0x4011393f in gtk_main () from /usr/lib/libgtk-x11-2.0.so.0
#23 0x08057f06 in main ()
#24 0x420165c4 in __libc_start_main () from /lib/i686/libc.so.6
(gdb) 

The bug seems to be in "vte"
Comment 1 Dams 2002-07-05 11:23:18 EDT
An additionnal info, It happens when i have an url in the epic prompt..
Dont know why exactly..
Comment 2 Havoc Pennington 2002-07-05 11:31:20 EDT
cc'ing nalin
Comment 3 Nalin Dahyabhai 2002-07-15 14:31:39 EDT
Did you have non-ASCII characters in the terminal at the time (for example,
characters with accents, umlauts, circumflexes, etc. over them)?  If so, then
this will be fixed in 0.4.9, and I'll close this bug when I get packages built.
Comment 4 Dams 2002-07-16 02:37:48 EDT
No. If I just put "http://asfgrgr" and move the mouse over the url then
gnome-terminal crashes.
Comment 5 Nalin Dahyabhai 2002-07-16 16:07:50 EDT
That's strange.  At least the case I mention above is fixed in 0.4.9, and this
has a good chance of fixing the problem you're running into.  Please check if
0.4.9 (coming soon to Raw Hide) fixes this for you.
Comment 6 Dams 2002-07-18 05:35:58 EDT
I have upgrade limbo with all packages i could found via up2date this morning.
gnome-terminal dont crash anymore. For me, this bug is fixed. :)
Thank you ! :)
Comment 7 Dams 2002-07-18 10:14:47 EDT
Just guess. :)
I have tested a little more and gnome-terminal just crashed down again.
This time "http://a.b.com" is okay but "http://a.b.com/" (with and ending slash)
make it crash.
Comment 8 Nalin Dahyabhai 2002-07-18 21:38:21 EDT
Okay, I think this is a corner case I missed.  It should be fixed in 0.5.0,
coming soon to Raw Hide (a new gnome-terminal build comes with it).  Please
reopen if you can cause it to crash again after updating.
Comment 9 Jay Turner 2002-07-30 08:24:49 EDT
Fix confirmed with vte-0.5.4-2 and gnome-terminal-2.0.0.90-3.

Note You need to log in before you can comment on or make changes to this bug.