Bug 679422 - guppy: undefined symbol: _PyLong_AsScaledDouble
Summary: guppy: undefined symbol: _PyLong_AsScaledDouble
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-guppy
Version: 14
Hardware: i686
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Lemenkov
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-22 14:34 UTC by Jan ONDREJ
Modified: 2011-03-14 05:37 UTC (History)
2 users (show)

Fixed In Version: python-guppy-0.1.9-4.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-13 21:22:29 UTC


Attachments (Terms of Use)

Description Jan ONDREJ 2011-02-22 14:34:39 UTC
Description of problem:
hpy module does not work in Fedora 14.

Version-Release number of selected component (if applicable):
python-guppy-0.1.9-2.fc14.i686

How reproducible:
always

Steps to Reproduce:
1. python
2. from guppy import hpy
3. x=hpy()
  
Actual results:
Error at initialization of module heapycTraceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib/python2.7/site-packages/guppy/__init__.py", line 37, in hpy
    return r.guppy.heapy.Use
  File "/usr/lib/python2.7/site-packages/guppy/etc/Glue.py", line 45, in __getattr__
    return self._share.getattr(self, name)
  File "/usr/lib/python2.7/site-packages/guppy/etc/Glue.py", line 195, in getattr 
    d = self.getattr2(inter, cache, owner, name)
  File "/usr/lib/python2.7/site-packages/guppy/etc/Glue.py", line 213, in getattr2
    x = self.getattr_package(inter, name)
  File "/usr/lib/python2.7/site-packages/guppy/etc/Glue.py", line 261, in getattr_package
    x = self.makeModule(x, name)
  File "/usr/lib/python2.7/site-packages/guppy/etc/Glue.py", line 321, in makeModule
    return Share(module, self, module.__name__, Clamp)
  File "/usr/lib/python2.7/site-packages/guppy/etc/Glue.py", line 184, in __init__
    getattr(inter, name)
  File "/usr/lib/python2.7/site-packages/guppy/etc/Glue.py", line 45, in __getattr__
    return self._share.getattr(self, name)
  File "/usr/lib/python2.7/site-packages/guppy/etc/Glue.py", line 195, in getattr
    d = self.getattr2(inter, cache, owner, name)
  File "/usr/lib/python2.7/site-packages/guppy/etc/Glue.py", line 215, in getattr2
    x = self.getattr3(inter, name)
  File "/usr/lib/python2.7/site-packages/guppy/etc/Glue.py", line 283, in getattr3
    pa = getattr(pa, at)
  File "/usr/lib/python2.7/site-packages/guppy/etc/Glue.py", line 45, in __getattr__
    return self._share.getattr(self, name)
  File "/usr/lib/python2.7/site-packages/guppy/etc/Glue.py", line 195, in getattr
    d = self.getattr2(inter, cache, owner, name)
  File "/usr/lib/python2.7/site-packages/guppy/etc/Glue.py", line 213, in getattr2
    x = self.getattr_package(inter, name)
  File "/usr/lib/python2.7/site-packages/guppy/etc/Glue.py", line 250, in getattr_package
    x = __import__(self.makeName(name), globals(), locals())
  File "/usr/lib/python2.7/site-packages/guppy/heapy/View.py", line 555, in <mod
  File "/usr/lib/python2.7/site-packages/guppy/heapy/View.py", line 555, in <module>
    prime_builtin_types()
  File "/usr/lib/python2.7/site-packages/guppy/heapy/View.py", line 538, in prime_builtin_types
    import guppy.heapy.heapyc
  File "/usr/lib/python2.7/site-packages/guppy/sets/__init__.py", line 3, in <module>
    from setsc import BitSet    # base bitset type
ImportError: /usr/lib/python2.7/site-packages/guppy/sets/setsc.so: undefined symbol: _PyLong_AsScaledDouble

Expected results:
next python prompt

Comment 1 Andrew McNabb 2011-03-04 20:48:55 UTC
I hit this exact same problem today, although my system is x86_64 instead of i686.  My traceback is nearly identical except for s/lib/lib64/ and for the first two or three stack frames (since I called guppy.hpy() from a script instead of from the interactive interpreter).  Is there any other information that Jan or I could provide to help track this down?  Thanks.

Comment 2 Andrew McNabb 2011-03-04 20:59:20 UTC
By the way, it looks like the same bug exists in Debian:

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=614498

and there's an upstream report here:

http://sourceforge.net/tracker/?func=detail&aid=3047282&group_id=105577&atid=641821

It looks like the upstream report is closed with a fix.  Could this be backported to the Fedora package pending a new upstream release with the fix?

Comment 3 Fedora Update System 2011-03-05 09:41:34 UTC
python-guppy-0.1.9-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/python-guppy-0.1.9-4.fc15

Comment 4 Fedora Update System 2011-03-05 09:41:58 UTC
python-guppy-0.1.9-4.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/python-guppy-0.1.9-4.fc14

Comment 5 Fedora Update System 2011-03-05 19:23:22 UTC
python-guppy-0.1.9-4.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update python-guppy'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/python-guppy-0.1.9-4.fc15

Comment 6 Fedora Update System 2011-03-13 21:22:24 UTC
python-guppy-0.1.9-4.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 7 Fedora Update System 2011-03-14 05:37:00 UTC
python-guppy-0.1.9-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.