Bug 679478 - KVM: when migrating a VM in status powering on, VM's OS becomes corrupted
KVM: when migrating a VM in status powering on, VM's OS becomes corrupted
Status: CLOSED DUPLICATE of bug 666225
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kvm (Show other bugs)
5.6
Unspecified Unspecified
low Severity urgent
: rc
: ---
Assigned To: Juan Quintela
Virtualization Bugs
:
Depends On:
Blocks: Rhel5KvmTier1
  Show dependency treegraph
 
Reported: 2011-02-22 11:39 EST by Dafna Ron
Modified: 2013-01-09 18:35 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-07 06:52:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
screen shot (43.07 KB, image/jpeg)
2011-02-22 11:39 EST, Dafna Ron
no flags Details
cpuinfo (924 bytes, application/x-gzip)
2011-02-23 03:15 EST, Dafna Ron
no flags Details

  None (edit)
Description Dafna Ron 2011-02-22 11:39:00 EST
Created attachment 480173 [details]
screen shot

Description of problem:

when migrating a VM with windoes based OS while the VM is in powering on state, we are getting guest file system corruption (OS will start normally after guest reboot).
 
tested in XP and Win2008. the error for XP is 
"windows could not start because the following file is missing or corrupt: system32:\DRIVERS\pci.sys

Windows2008:
Windows failed to start. a recent hardware or software change might be the cause 



Version-Release number of selected component (if applicable):
ic92 rhevm build

Source host: 5.6  
[root@blond-vdsf ~]# uname -r
2.6.18-238.1.1.el5

[root@blond-vdsf ~]# rpm -qa |grep vds
vdsm22-4.5-63.19.el5_6
vdsm22-faqemu-4.5-63.19.el5_6
vdsm22-reg-4.5-63.19.el5_6
vdsm22-cli-4.5-63.19.el5_6
vdsm22-debuginfo-4.5-63.19.el5_6

[root@blond-vdsf ~]# rpm -qa |grep qemu
vdsm22-faqemu-4.5-63.19.el5_6
kvm-qemu-img-83-224.el5


destination host: rhevh5
[root@blond-vdsg ~]# uname -r
2.6.18-238.el5

[root@blond-vdsg ~]# rpm -qa |grep vdsm
vdsm22-4.5-63.9.el5
vdsm22-cli-4.5-63.9.el5
vdsm22-reg-4.5-63.9.el5

[root@blond-vdsg ~]# rpm -qa |grep qemu
kvm-qemu-img-83-224.el5
gpxe-roms-qemu-0.9.7-8.el5


both hosts are AMD

How reproducible:
100%

Steps to Reproduce:

On a two hosts cluster:

1. create a VM with windows OS 
2. start the VM 
3. Migrate when the VM is in "powering up" state
  
Actual results:

the VM will migrate and you will get corruption in the VM's OS

Expected results:

the VM's OS should not be affected by the migration. 

Additional info: 
screen shot attached.
Comment 1 Dafna Ron 2011-02-23 03:15:44 EST
Created attachment 480376 [details]
cpuinfo

adding information on the hosts:

source: 

[root@blond-vdsf ~]# rpm -qa |grep kvm
kvm-83-224.el5
kvm-debuginfo-83-224.el5
kvm-qemu-img-83-224.el5
kvm-tools-83-224.el5
etherboot-zroms-kvm-5.4.4-13.el5
kmod-kvm-83-224.el5


destination:

[root@blond-vdsg ~]# rpm -qa |grep kvm
etherboot-zroms-kvm-5.4.4-13.el5
kmod-kvm-83-224.el5
kvm-tools-83-224.el5
kvm-qemu-img-83-224.el5
kvm-debuginfo-83-224.el5
kvm-83-224.el5


attached is the cpu info on both hosts.
Comment 5 Mike Cao 2011-07-18 04:50:39 EDT
Hi, Dafna Ron 

Does it still exists ?

FYI ,I think this bug is dup of https://bugzilla.redhat.com/show_bug.cgi?id=693894
Comment 8 Dor Laor 2011-08-07 06:52:28 EDT

*** This bug has been marked as a duplicate of bug 666225 ***

Note You need to log in before you can comment on or make changes to this bug.