Bug 679490 - [a11y] LibreOffice Writer hangs when switching view to "Web layout"
[a11y] LibreOffice Writer hangs when switching view to "Web layout"
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
rawhide
i686 Linux
low Severity low
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-22 12:51 EST by kentontofte
Modified: 2011-10-27 05:59 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-27 05:59:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hacky demo (23.67 KB, patch)
2011-04-07 12:07 EDT, Caolan McNamara
no flags Details | Diff

  None (edit)
Description kentontofte 2011-02-22 12:51:55 EST
Description of problem:
LibreOffice Writer has trouble switching to the "Web layout" view when a document is open. The CPU spikes, and the program freezes temporarily. It becomes nearly unusable with large documents.


Version-Release number of selected component (if applicable): LibreOffice 3.3.0.4-1.fc15


How reproducible:
Easily reproducible with different documents. Most noticeable with large ones (50+ pages).

Steps to Reproduce:
1. Open .odt document from Nautilus.
2. In LibreOffice Writer, go to "View" and click "Web layout".
  
Actual results:
Program freezes for different lengths of time (15 seconds to several minutes), depending on the size of the document. Sometimes (but rarely) affects entire desktop.

Expected results:
Fairly quick change from print to web layout.

Additional info:
Happens while running latest Rawhide (as of 22 Feb 2011) on a Lenovo Thinkpad R61 with 2 GHz Intel Core 2 Duo CPU and 2 GB RAM.
Comment 1 Caolan McNamara 2011-02-22 15:35:59 EST
Attach a specific example
Comment 2 David Tardon 2011-03-16 08:13:57 EDT
Caused by a11y. If you turn it off, i.e., run

gconftool-2 -s /desktop/gnome/interface/accessibility -t boolean false

, the change will be fairly quick.
Comment 3 Caolan McNamara 2011-03-30 15:29:09 EDT
Indeed http://www.oasis-open.org/committees/download.php/12573/OpenDocument-v1.0-os.sxw hangs on switch
Comment 4 Caolan McNamara 2011-03-30 16:25:30 EDT
looks like its insanely slow and busy rather than in a simple hang
Comment 5 David Tardon 2011-03-31 00:34:44 EDT
Yes, exactly. I was going to mention this, but I see I haven't...
Comment 6 Caolan McNamara 2011-04-07 12:07:03 EDT
Created attachment 490585 [details]
hacky demo

Well, hacking this makes it from never ends, to just completely unacceptably slow and leaving unsafe SwAccessibleEvent_Impl dangling pointing to deleted objects.
Comment 7 David Tardon 2011-10-27 05:59:22 EDT
I have not been able to reproduce the slowdown ever since, so I am going to blame it on at-spi2 or something related.

Note You need to log in before you can comment on or make changes to this bug.