Bug 679503 - plymouth doesn't always transition to gdm
plymouth doesn't always transition to gdm
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: plymouth (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
: 682327 (view as bug list)
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-02-22 13:31 EST by James Laska
Modified: 2013-09-02 02:55 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-18 14:02:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/plymouth-debug.log (178.19 KB, text/plain)
2011-02-22 13:31 EST, James Laska
no flags Details

  None (edit)
Description James Laska 2011-02-22 13:31:26 EST
Created attachment 480197 [details]
/var/log/plymouth-debug.log

Description of problem:

Every 4 or 5 boot ups, plymouth fails to transition to the graphical login (gdm).

Version-Release number of selected component (if applicable):
 * plymouth-0.8.4-0.20110209.2.fc15.x86_64
 * systemd-18-1.fc15.x86_64
 * gdm-2.91.6-9.fc15.x86_64
 
How reproducible:
 1 of every 4 or 5 system boots

Steps to Reproduce:
1. Boot a system
2. Enter passphrase for encrypted '/' and swap partitions
  
Actual results:

Plymouth continues to show graphical boot progress, and doesn't transition to gdm.  I can chvt and login on different tty's

Expected results:

Graphical display manager (gdm)

Additional info:

 * See attached plymouth:debug log
 * When plymouth got stuck, I logged in via tty2 and killed plymouthd
   # pkill -SEGV -f plymouthd
Comment 1 Lennart Poettering 2011-03-06 09:40:36 EST
*** Bug 682327 has been marked as a duplicate of this bug. ***
Comment 2 Adam Williamson 2011-03-10 13:57:50 EST
I was seeing this consistently on live images I was building for the GNOME 3 Test Day; on my test laptop gdm would never start, the live image just booted to a console and systemd said prefdm.service start was 'waiting'.

I had to add rd_NO_PLYMOUTH to the live image boot parameters to avoid this.
Comment 3 Adam Williamson 2011-03-11 13:38:56 EST
Discussed at 2011-03-11 blocker review meeting. We'd like a little more data to be sure of the impact of this one; I was testing only on one system so if this is timing dependent it may not hit other systems. This issue should be present on current nightlies (as they don't have the workaround of disabling Plymouth), so feedback from people testing the nightlies would be useful.
Comment 4 Joachim Frieben 2011-03-11 16:56:08 EST
I haven't observed this issue for a fully updated F15 anymore for a few days now.
Comment 5 James Laska 2011-03-18 13:58:31 EDT
(In reply to comment #4)
> I haven't observed this issue for a fully updated F15 anymore for a few days
> now.

Likewise, I've not seen this problem in a long time on my existing F-15 install.
Comment 6 Adam Williamson 2011-03-18 14:02:35 EDT
Discussed at 2011-03-18 blocker review meeting. This was proposed due to issues I was seeing with the test day live images, but we decided to close this as neither reporter is seeing the initial issue any more. I will file a new bug if latest nightlies still have problems on my test system.

Note You need to log in before you can comment on or make changes to this bug.