Bug 679505 - Rotation fails.
Rotation fails.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
: 679657 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-22 13:41 EST by Tom Atkinson
Modified: 2011-03-26 01:08 EDT (History)
6 users (show)

See Also:
Fixed In Version: xorg-x11-drv-nouveau-0.0.16-24.20110324git8378443.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-26 01:08:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (970.04 KB, image/jpeg)
2011-02-22 13:59 EST, Tom Atkinson
no flags Details
Xorg.0.log (32.65 KB, text/plain)
2011-02-22 14:06 EST, Tom Atkinson
no flags Details
dmesg (80.99 KB, text/plain)
2011-02-22 14:09 EST, Tom Atkinson
no flags Details
xorg.conf disabling page flipping (108 bytes, application/octet-stream)
2011-02-23 19:33 EST, Ben Skeggs
no flags Details

  None (edit)
Description Tom Atkinson 2011-02-22 13:41:43 EST
Attempted rotation on the test day livecd.

Rotation +/-90 degrees results in display corruption. Rotation by 180 degrees inverts the mouse but not the display. The settings do revert to normal as expected after the timeout.

Rotation works fine in Fedora 14.

Smolt: http://www.smolts.org/client/show/pub_16a6caad-d145-4a1e-bd74-a2ac05c34ea3
Comment 1 Tom Atkinson 2011-02-22 13:59:12 EST
Created attachment 480207 [details]
Screenshot
Comment 2 Tom Atkinson 2011-02-22 14:06:37 EST
Created attachment 480212 [details]
Xorg.0.log
Comment 3 Tom Atkinson 2011-02-22 14:09:10 EST
Created attachment 480213 [details]
dmesg
Comment 4 Sebastian Rasmussen 2011-02-22 20:42:45 EST
I see the same problem for cw/ccw rotatino, although I should specifically mention that I do se the screen rotated 180 degrees for 2 seconds before it flips back to normal and leaving the mouse pointed and directions inverted (until the expected timeout kicks in).

Smolt:
http://smolts.org/client/show/pub_6833947c-d3ee-4790-ab43-fc7431c36dd9
Comment 5 Ben Skeggs 2011-02-23 19:33:03 EST
Created attachment 480613 [details]
xorg.conf disabling page flipping

Are you able to install this xorg.conf to /etc/X11/xorg.conf, and restart X and see if this issue is resolved?

If not, can I see /var/log/Xorg.0.log for the new X session.
Comment 6 Ben Skeggs 2011-02-24 00:44:07 EST
*** Bug 679657 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2011-02-24 01:18:19 EST
xorg-x11-drv-nouveau-0.0.16-20.20110224gitbc5dec2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xorg-x11-drv-nouveau-0.0.16-20.20110224gitbc5dec2.fc15
Comment 8 Tom Atkinson 2011-02-24 11:59:54 EST
The updated package fixes the bug. Good job.
Comment 9 Fedora Update System 2011-02-25 18:17:56 EST
xorg-x11-drv-nouveau-0.0.16-20.20110224gitbc5dec2.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update xorg-x11-drv-nouveau'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/xorg-x11-drv-nouveau-0.0.16-20.20110224gitbc5dec2.fc15
Comment 10 Vlad 2011-03-01 10:48:36 EST
Fixed for me after update. 
Sorry for late answer - it's not my video card, so i had no possibility to test it again until now.
Comment 11 Fedora Update System 2011-03-09 02:18:39 EST
xorg-x11-drv-nouveau-0.0.16-22.20110303git92db2bc.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xorg-x11-drv-nouveau-0.0.16-22.20110303git92db2bc.fc15
Comment 12 Sebastian Rasmussen 2011-03-13 21:43:48 EDT
Sorry for the delay, I've been caught up in work in the real world. :-/
I've bought a USB stick to use for testing though so I hope to retest this and return to you with answers during the coming week.

 / Sebastian
Comment 13 Fedora Update System 2011-03-23 03:20:41 EDT
xorg-x11-drv-nouveau-0.0.16-24.20110324git8378443.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xorg-x11-drv-nouveau-0.0.16-24.20110324git8378443.fc15
Comment 14 Fedora Update System 2011-03-26 01:08:11 EDT
xorg-x11-drv-nouveau-0.0.16-24.20110324git8378443.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.