SSO (single sign-on) is being reconfigured. Maintenance started Jul 16 2:20PM UTC and will last 1 hour. Password-enabled login should still work.
Bug 679581 - "grubby --info=ALL" segfaults with dual boot parameters in grub.conf
Summary: "grubby --info=ALL" segfaults with dual boot parameters in grub.conf
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd
Version: 5.6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Brian Lane
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 726828
TreeView+ depends on / blocked
 
Reported: 2011-02-22 22:07 UTC by Kendrick Gay
Modified: 2018-11-26 19:20 UTC (History)
5 users (show)

Fixed In Version: mkinitrd-5.1.19.6-73
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-21 05:33:58 UTC
Target Upstream Version:


Attachments (Terms of Use)
commit 173351118ccb5b3595168a701fa7b4c1b9804106 (850 bytes, patch)
2011-03-02 00:55 UTC, Brian Lane
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0157 normal SHIPPED_LIVE mkinitrd bug fix update 2012-02-20 14:54:17 UTC

Description Kendrick Gay 2011-02-22 22:07:02 UTC
Description of problem:
When using grubby to parse boot parameters, it segfaults:

[root@gss-rhel5u5-32 ~]# grep -v ^# /etc/grub.conf 
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
serial --unit=0 --speed=115200 --word=8 --parity=no --stop=1
terminal --timeout=5 serial console
title Red Hat Enterprise Linux Server (2.6.18-194.26.1.el5)
	root (hd0,0)
	kernel /vmlinuz-2.6.18-194.26.1.el5 ro root=/dev/vg0/root console=ttyS0,115200 rhgb quiet
	initrd /initrd-2.6.18-194.26.1.el5.img
title Red Hat Enterprise Linux Server (2.6.18-194.el5)
	root (hd0,0)
	kernel /vmlinuz-2.6.18-194.el5 ro root=/dev/vg0/root console=ttyS0,115200 rhgb quiet
	initrd /initrd-2.6.18-194.el5.img
title Other
       rootnoverify (hd0,0)
       chainloader +1
[root@gss-rhel5u5-32 ~]# grubby --info=ALL
boot=/dev/vda
index=0
kernel=/vmlinuz-2.6.18-194.26.1.el5
args="ro console=ttyS0,115200 rhgb quiet"
root=/dev/vg0/root
initrd=/boot/initrd-2.6.18-194.26.1.el5.img
index=1
kernel=/vmlinuz-2.6.18-194.el5
args="ro console=ttyS0,115200 rhgb quiet"
root=/dev/vg0/root
initrd=/boot/initrd-2.6.18-194.el5.img
index=2
Segmentation fault

Version-Release number of selected component (if applicable):
mkinitrd-5.1.19.6-68.el5

How reproducible:
Setup dual boot system with Windows, then run "grubby --info=ALL" in RHEL

Steps to Reproduce:
1. Verify GRUB parameters for Windows in grub.conf
2. Run "grubby --info=ALL"
3. Observe segfault once parameters for Windows boot are accessed
  
Actual results:
grubby segfaults with Windows boot definitions in grub.conf

Expected results:
grubby ignores Windows boot definitions in grub.conf, or returns "non linux entry", as it does in later versions (grubby-7.0.x).

Additional info:

Comment 2 Brian Lane 2011-03-02 00:55:05 UTC
Created attachment 481756 [details]
commit 173351118ccb5b3595168a701fa7b4c1b9804106

This patch from the grubby repo will fix this.

Comment 4 RHEL Program Management 2011-08-05 12:32:18 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 6 Pavel Holica 2011-12-21 09:34:35 UTC
Reproduced on RHEL5.7 Client x86_64
Verified on RHEL5.8-Client-20111214.0.

Comment 7 errata-xmlrpc 2012-02-21 05:33:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0157.html


Note You need to log in before you can comment on or make changes to this bug.