Bug 679596 - s-c-selinux - could not open interface info
Summary: s-c-selinux - could not open interface info
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils
Version: 15
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 1435729
TreeView+ depends on / blocked
 
Reported: 2011-02-22 22:52 UTC by Flóki Pálsson
Modified: 2017-03-24 15:38 UTC (History)
4 users (show)

Fixed In Version: policycoreutils-2.0.85-19.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1435729 (view as bug list)
Environment:
Last Closed: 2011-03-12 04:40:13 UTC


Attachments (Terms of Use)

Description Flóki Pálsson 2011-02-22 22:52:54 UTC
Description of problem:
Can not start system-config-selinux from menu or terminal.

Version-Release number of selected component (if applicable):
policycoreutils-gui-2.0.85-12.fc15.x86_64

How reproducible:
always 

Steps to Reproduce:
1. $ system-config-selinux  from termonal
2. type root passwor in window 
3.
  
Actual results:
floki@f15a ~]$ system-config-selinux

** (system-config-selinux.py:2044): WARNING **: AT-SPI: Accessibility bus not found - Using session bus.

could not open interface info [/var/lib/sepolgen/interface_info]
[floki@f15a ~]$ ^C

Expected results:
To see system-config-selinux in GUI

Additional info:
This is newly installed F15 from RC1 Fedora-15-Alpha-x86_64-Live-Desktop.iso.
Fully updated 
and installed policycoreutils-gui

Comment 1 Daniel Walsh 2011-02-23 21:11:02 UTC
Strange,are you running an SELinux enabled system?

sepolgen-ifgen 

Should create that file.

Comment 2 Flóki Pálsson 2011-02-23 22:56:39 UTC
Ok now after last update 

Additional info:
[floki@f15a ~]$ /usr/bin/system-config-selinux

** (system-config-selinux.py:2295): WARNING **: AT-SPI: Accessibility bus not found - Using session bus.

/usr/share/system-config-selinux/system-config-selinux.py:71: Warning: g_object_get_valist: object class `GnomeProgram' has no property named `default-icon'
  xml = gtk.glade.XML ("/usr/share/system-config-selinux/system-config-selinux.glade", domain=PROGNAME)
/usr/share/system-config-selinux/system-config-selinux.py:181: Warning: cannot retrieve class for invalid (unclassed) type `<invalid>'
  gtk.main()
[floki@f15a ~]$ 

>Strange,are you running an SELinux enabled system?
This is dfault setup from RC1 live.
[floki@f15a ~]$ sepolgen-ifgen
could not open output file [/var/lib/sepolgen/interface_info]

[root@f15a ~]# sepolgen-ifgen
[root@f15a ~]# 
same result with $ /usr/bin/system-config-selinux

Comment 3 Daniel Walsh 2011-02-24 18:25:57 UTC
lets try

yum reinstall selinux-policy-targeted

This looks like a bad install.

Comment 4 Clyde E. Kunkel 2011-03-03 17:57:13 UTC
clean install of F15ARC2 and updates-testing, but getting a failure:

$ sudo system-config-selinux
/usr/share/system-config-selinux/system-config-selinux.py:71: Warning: g_object_get_valist: object class `GnomeProgram' has no property named `default-icon'
  xml = gtk.glade.XML ("/usr/share/system-config-selinux/system-config-selinux.glade", domain=PROGNAME)
Traceback (most recent call last):
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 186, in <module>
    app = childWindow()
  File "/usr/share/system-config-selinux/system-config-selinux.py", line 89, in __init__
    self.add_page(portsPage.portsPage(xml))
  File "/usr/share/system-config-selinux/portsPage.py", line 69, in __init__
    self.load()
  File "/usr/share/system-config-selinux/portsPage.py", line 131, in load
    self.store.set_value(iter, PORT_COL, k[0])
TypeError: value is of the wrong type for this column

Comment 5 Daniel Walsh 2011-03-09 21:48:29 UTC
Fixed in policycoreutils-2.0.85-19.fc15

Comment 6 Fedora Update System 2011-03-09 22:02:26 UTC
policycoreutils-2.0.85-19.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/policycoreutils-2.0.85-19.fc15

Comment 7 Clyde E. Kunkel 2011-03-10 00:29:50 UTC
Confirm fix works.

Comment 8 Daniel Walsh 2011-03-10 16:05:29 UTC
Update karma please.

Comment 9 Fedora Update System 2011-03-12 04:39:59 UTC
policycoreutils-2.0.85-19.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Suhan Andrei 2012-03-28 21:20:55 UTC
looks like problem still exists in fc15: 

"
[root@cb ~]#system-config-selinux
could not open interface info [/var/lib/sepolgen/interface_info]
[root@cb ~]# rpm -q policycoreutils
policycoreutils-2.0.86-7.fc15.x86_64
[root@cb ~]# uname -a
Linux cb-fc15 2.6.42.9-2.fc15.x86_64 #1 SMP Mon Mar 5 20:55:32 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
"


this is running as guest in a vmware host .

Comment 11 Miroslav Grepl 2012-03-29 06:48:38 UTC
Does the "/var/lib/sepolgen/interface_info" file exist?

Comment 12 Suhan Andrei 2012-03-29 09:38:51 UTC
No it does not exists.

ls -la /var/lib/sepolgen/interface_info
ls: cannot access /var/lib/sepolgen/interface_info: No such file or directory

Comment 13 Daniel Walsh 2012-03-29 17:39:00 UTC
Suhan

Execute

sepolgen-ifgen

Does this blow up?

Comment 14 Suhan Andrei 2012-03-30 01:03:09 UTC
after running sepolgen-ifgen  system-config-selinux shows up. Thanks.


Note You need to log in before you can comment on or make changes to this bug.