Bug 679679 - myproxy requires deprecated voms library
Summary: myproxy requires deprecated voms library
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: myproxy
Version: el5
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Steve Traylen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-23 08:07 UTC by CristinaA
Modified: 2011-03-12 22:54 UTC (History)
2 users (show)

Fixed In Version: myproxy-5.3-3.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-03 02:56:09 UTC


Attachments (Terms of Use)

Description CristinaA 2011-02-23 08:07:54 UTC
Description of problem:
It seems that myproxy is reguireing the presence of libvomsc, but the developer (VincenzoC) comunicated some time ago that this library should not be used anymore as it was replaced by libvomsapi.
"libvomsc is nothing more than a libvomsapi renamed, and has been deprecated since 2006" (citing Vincenzo)

The voms available in EPEL is providing both libvomsc and libvomsapi.

Could the requires be changed from libvomsc to libvomsapi?

Version-Release number of selected component (if applicable):
myproxy 5.3-1.el5

How reproducible:

# rpm -qp --requires http://download.fedora.redhat.com/pub/epel/5/x86_64/myproxy-5.3-1.el5.x86_64.rpm

Steps to Reproduce:
1.
2.
3.
  
Actual results:
[...]
libvomsc.so.0()(64bit)
[...]

Expected results:
[...]
libvomsapi.so.0()(64bit)
[...]

Additional info:

Comment 1 Fedora Update System 2011-02-23 08:22:41 UTC
myproxy-5.3-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/myproxy-5.3-3.el5

Comment 2 Fedora Update System 2011-02-23 08:22:43 UTC
myproxy-5.3-3.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/myproxy-5.3-3.fc14

Comment 3 Fedora Update System 2011-02-23 08:22:45 UTC
myproxy-5.3-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/myproxy-5.3-3.fc15

Comment 4 Fedora Update System 2011-02-23 08:22:58 UTC
myproxy-5.3-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/myproxy-5.3-3.el6

Comment 5 Fedora Update System 2011-02-23 08:23:32 UTC
myproxy-5.3-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/myproxy-5.3-3.el5

Comment 6 Steve Traylen 2011-02-23 08:24:53 UTC
It looks like myproxy was the last thing using vomsc rather than vomsapi in Fedora so the change
makes sense.

Steve.

Comment 7 Fedora Update System 2011-02-23 20:29:34 UTC
myproxy-5.3-3.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update myproxy'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/myproxy-5.3-3.fc15

Comment 8 Fedora Update System 2011-03-03 02:56:01 UTC
myproxy-5.3-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2011-03-10 17:25:54 UTC
myproxy-5.3-3.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2011-03-10 17:26:58 UTC
myproxy-5.3-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2011-03-12 22:54:45 UTC
myproxy-5.3-3.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.