Bug 679699 - Mouse does not move in PV Xen guest under CentOS-5.5
Summary: Mouse does not move in PV Xen guest under CentOS-5.5
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-evdev
Version: 14
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Hutterer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-23 09:17 UTC by Alejandro Liu
Modified: 2018-04-11 09:51 UTC (History)
2 users (show)

Fixed In Version: xorg-x11-server-1.9.5-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-04-05 05:18:58 UTC


Attachments (Terms of Use)
Output of dmesg command (5.99 KB, application/x-gzip)
2011-03-10 04:12 UTC, Alejandro Liu
no flags Details
Contents of /var/log/messages (5.75 KB, application/x-gzip)
2011-03-10 04:12 UTC, Alejandro Liu
no flags Details
Contents of /var/log/Xorg.0.log (3.36 KB, application/x-gzip)
2011-03-10 04:13 UTC, Alejandro Liu
no flags Details
diff -u 10-quirks.conf.f13 10-quirks.conf.f14 (609 bytes, patch)
2011-03-10 08:55 UTC, Matěj Cepl
no flags Details | Diff

Description Alejandro Liu 2011-02-23 09:17:06 UTC
NOTE: 
This seems to be the same bug as Bug 523914 - which was fixed in Fedora-13 but has since regressed with Fedora-14.

Description of problem:

Mouse stays in the center of the screen and does not move when Fedora is
started as a PV guest on CentOS-5.5 Xen. However clicking and scrolling with
wheel work fine. This happens even during installation.

Version-Release number of selected component (if applicable):

X.Org X Server 1.9.4

How reproducible:

100%

Steps to Reproduce:
1. start Fedora installation on RHEL-5.4 Xen as a PV guest with 1500MB memory,
4 CPUs, and 4GB disk
2. wait until graphical anaconda appears

Actual results:

Mouse does not move but mouse buttons work fine

Expected results:

Working mouse

Additional info:

Xen in CentOS-5.5 provides absolute pointer for F14 PV guests but in Fedora X log
says:

(II) Xen Virtual Pointer: initialized for relative axes.
(WW) Xen Virtual Pointer: ignoring absolute axes.

which is probably the reason of this bug...

Comment 1 Alejandro Liu 2011-02-23 09:24:04 UTC
In Fedora 13 the file:

/usr/share/X11/xorg.conf.d/10-quirks.conf 

Contains the lines:

# https://bugzilla.redhat.com/show_bug.cgi?id=523914
# Mouse does not move in PV Xen guest
# Explicitly tell evdev to not ignore the absolute axes.
Section "InputClass"
        Identifier "Xen Virtual Pointer axis blacklist"
        MatchProduct "Xen Virtual Pointer"
        Option "IgnoreAbsoluteAxes" "off"
        Option "IgnoreRelativeAxes" "off"
EndSection

Adding this lines to the same file (Part of xorg-x11-server-Xorg) fixes the problem.

Comment 2 Matěj Cepl 2011-03-08 23:37:45 UTC
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.

Comment 3 Alejandro Liu 2011-03-10 04:12:10 UTC
Created attachment 483352 [details]
Output of dmesg command

Comment 4 Alejandro Liu 2011-03-10 04:12:55 UTC
Created attachment 483353 [details]
Contents of /var/log/messages

Comment 5 Alejandro Liu 2011-03-10 04:13:33 UTC
Created attachment 483354 [details]
Contents of /var/log/Xorg.0.log

Comment 6 Alejandro Liu 2011-03-10 04:21:26 UTC
Hello,

I have attached the files as requested.  I do not have a Xorg.conf file.

I don't see what all this information is needed.  Essentially the problem was fixed in Fedora-13 with the file /usr/share/X11/xorg.conf.d/10-quirks.conf from xorg-x11-server-Xorg.

For Fedora-14 that file was dropped.  If I create that file manually on Fedora-14, the problem is solved.

Somewhere in the history of the package that file was dropped, thus re-introducing the bug.  The full discussion is in the previous bug report: Bug 523914

Comment 7 Matěj Cepl 2011-03-10 08:18:03 UTC
Yes, you are right ... I have misread your original description. We had to drop the file somewhere. Peter?

Comment 8 Matěj Cepl 2011-03-10 08:55:37 UTC
Created attachment 483389 [details]
diff -u 10-quirks.conf.f13 10-quirks.conf.f14

Yes, you are right ... we have dropped Xen-related stuff somewhere.

Comment 9 Fedora Update System 2011-03-11 02:59:39 UTC
xorg-x11-server-1.9.4-2.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.9.4-2.fc14

Comment 10 Fedora Update System 2011-03-11 03:03:14 UTC
xorg-x11-server-1.10.0-3.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.10.0-3.fc15

Comment 11 Fedora Update System 2011-03-14 05:37:44 UTC
xorg-x11-server-1.10.0-3.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2011-03-18 00:40:44 UTC
xorg-x11-server-1.9.5-1.fc14 has been submitted as an update for Fedora 14.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.9.5-1.fc14

Comment 13 Fedora Update System 2011-04-05 05:18:54 UTC
xorg-x11-server-1.9.5-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.