This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 679822 - Checkbox usability request in Compliance Assistant
Checkbox usability request in Compliance Assistant
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.1
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Bryan Kearney
J.C. Molet
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-02-23 10:34 EST by J.C. Molet
Modified: 2013-01-10 05:50 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:13:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description J.C. Molet 2011-02-23 10:34:18 EST
Description of problem:
When using the compliance assistant one has to check all the products they want to show in the subscriptions field.  After a subscription is subscribed to, the window refreshes: the newly 'in-compliance' products are removed from the products, the search is updated, and all the products are unchecked.  To continue searching for subscriptions, you have to check all the boxes you want again and again until you are done with the tool.  This makes the tool a bit unwieldy.

What I propose:
- A check/uncheck all checkbox at the top of the column.
- Check box state is remembered across subscribes (if it was checked before subscribing to something, it will still be checked after subscribing if the product is still in the list).
Comment 3 James Bowes 2011-08-04 12:40:55 EDT
fixed in master, a20793c1a6f2ab4d5ab253cb7fc709e5faa586f8
Comment 4 James Bowes 2011-08-08 10:35:01 EDT
oops, didn't add the check/uncheck all option. i'll do that now.
Comment 5 James Bowes 2011-08-10 10:21:54 EDT
check/uncheck all now in master, 8802aebfc8a89e6f2c904f912512dad3dd50dc53
Comment 7 J.C. Molet 2011-08-11 12:50:37 EDT
This works as described, the check all button even follows keyboard accessibility with alt + C 

subscription-manager-gnome-0.96.5-1.git.19.8802aeb.el6.x86_64

moving to VERIFIED.
Comment 8 errata-xmlrpc 2011-12-06 12:13:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.