Bug 67996 - Plain text prints outside proper margins
Plain text prints outside proper margins
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-05 00:07 EDT by Matthew Saltzman
Modified: 2007-04-18 12:43 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-07 16:54:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2002-07-05 00:07:19 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.9) Gecko/20020513

Description of problem:
Sending a plain text file to my Lexmark Optra Ep results in a printed page with
the left and top margins off the edge of the page.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Define a Lexmark Optra Ep printer in CUPS (I don't know if the problem occurs
with other printers).
2. Print a plain ascii file to that printer using "lp" or "lpr".
3. Look at the printed page.
	

Actual Results:  The page prints with the top line and column 1 off the page.

Expected Results:  The page should print with reasonable margins, probably 80
cols by 66 lines.

Additional info:

Printing explicitly through a Postscript printer (e.g., "mpage -1 foo.txt  |
lpr" prints a properly formatted page.
Comment 1 Matthew Saltzman 2002-08-21 15:01:49 EDT
The problem is not limited to the Lexmark Optra Ep driver.  Plain text printed
to an HP PostScript printer exhibits the same behavior.
Comment 2 Tim Waugh 2002-09-26 03:27:14 EDT
This will be because the imageable area is set to the entire page area in the  
PPD files generated by foomatic.  
  
For the time being, edit the PPD file in /etc/cups/ppd and change the:  
  
*ImageableArea Letter/Letter: "0 0 612 792"  
  
line to:  
  
*ImageableArea Letter/Letter: "18 36 594 756"  
  
A future version of the Red Hat printer configuration tool will set page  
margins automatically for CUPS print queues. 
 
(Closing as 'rawhide' since this tool will shortly show up in rawhide..)
Comment 3 Gerry Tool 2002-10-08 08:38:59 EDT
This solution (changing the imageablearea spec) does not solve the problem with
printing from KMail.  Margin control is very welcome, but there is a definite
problem between KMail (and othe KDE apps) and the formatting/printing of pages.
 The particular suggestion of *ImageableArea Letter/Letter: "18 36 594 756"
pushes the top of a KMail page off the paper and still results in a missing line
between first and second pages.  I will try to file a bugzilla against KDE
describing this problem.
Comment 4 Tim Waugh 2002-10-08 08:52:53 EDT
I'll reopen this for the time being.
Comment 5 Matthew Saltzman 2002-10-08 09:41:55 EDT
The proposed solution does indeed cause the full imageable area to appear on the
printed page, so half the problem is solved.  But the page is still 80 cols x 60
lines, which is not the standard page layout.  Piping through mpage as described
above produces a page layout that's standard 80x66.  It is possible that this
causes the incorrect pagination in KMail (though I'm not a KMail user, so I
can't investigate that further).
Comment 6 Tim Waugh 2002-10-08 09:47:08 EDT
Set options 'cpi=12' and 'lpi=7', and also 'wrap=true'?
Comment 7 Matthew Saltzman 2004-07-07 14:34:39 EDT
The margin problem is still an issue in Fedora Core 2.  From the
Lexmark Optra Ep ppd:

*ImageableArea Letter/US Letter: "0 0 612 792"

Haven't checked the 66-line issue yet.
Comment 8 Tim Waugh 2004-07-07 16:54:02 EDT
Change these values using the system-config-printer tool.  They are
not set that way by default for new queues.
Comment 9 Matthew Saltzman 2004-07-07 18:03:55 EDT
What exactly do I need to set?  In the "Queue Options" tab, it doesn't
appear that neither the margins (all default 36pt) nor the filter
options page-top, page-bottom, page-left, and page-right affect the
ImageableArea setting.

Thanks.
Comment 10 Tim Waugh 2004-07-09 05:50:38 EDT
Margins.  But have you added a vendor PPD, or did you set up
everything using system-config-printer?  If a vendor PPD, how did you
add it?
Comment 11 Matthew Saltzman 2004-07-09 06:52:51 EDT
It's the system-config-printer PPD for the recommended Lexmark Optra
Ep PostScript driver (in fact, the only driver choice listed for this
printer).  If you want to see it I can attach it.

Will changing the margins shrink the size of the image or will it
change the line width and page height?  Changing the imageable area
does not change the maargins reported by system-config-printer. 
Recall the other point of this bug, that a standard text page should
be 80x66.
Comment 12 Tim Waugh 2004-07-09 07:39:58 EDT
You can't change the PPD by hand, but instead must make changes
through the system-config-printer tool.  The effect of ImageableArea
depends on the application that generates the print job.  For printing
text, it sets the margins used by the texttops filter.

Note You need to log in before you can comment on or make changes to this bug.