Bug 67997 - up2date fails to run (eg: up2date -u) gets traceback msgs
Summary: up2date fails to run (eg: up2date -u) gets traceback msgs
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: up2date (Show other bugs)
(Show other bugs)
Version: limbo
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Adrian Likins
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67217
TreeView+ depends on / blocked
 
Reported: 2002-07-05 04:13 UTC by Ryan Weiss
Modified: 2015-01-07 23:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-09 02:53:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from rpm -qa (12.75 KB, text/plain)
2002-07-05 04:15 UTC, Ryan Weiss
no flags Details

Description Ryan Weiss 2002-07-05 04:13:33 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
after doing an upgrade from 7.3, I tried using up2date - it failed and kicked
out traceback messages

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade 7.3 install
2. run up2date -u
3. see error message
	

Actual Results:  [root@localhost sbin]# up2date -u
Adding cert <X509Name object '/C=US/ST=North Carolina/L=Research Triangle Park/O
=Red Hat, Inc./OU=Red Hat Network Services/CN=RHNS Certificate Authority/Email=r
hns@redhat.com'>
Traceback (most recent call last):
  File "/usr/sbin/up2date", line 785, in ?
    main()
  File "/usr/sbin/up2date", line 489, in main
    up2dateAuth.updateLoginInfo()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 110, in updateLoginI
nfo
    loginInfo = login()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 96, in login
    maybeUpdateVersion()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 59, in maybeUpdateVe
rsion
    except rpclib.Fault, f:
NameError: global name 'rpclib' is not defined

Expected Results:  checked with redhat for updates to the OS

Additional info:

Comment 1 Ryan Weiss 2002-07-05 04:15:09 UTC
Created attachment 63724 [details]
output from rpm -qa

Comment 2 Nathan G. Grennan 2002-07-06 05:17:33 UTC
Ncurses up2date definitely seems broken. Gtk up2date seems to have problems, but
limps along. It finally runs into the problem of there is(not sure if it has
changed since I last tried) no Limbo up2date channel.

Comment 3 Adrian Likins 2002-08-09 02:53:44 UTC
fixed in current beta versions, (2.9.30+ should work...)

Comment 4 Jay Turner 2002-08-19 18:52:45 UTC
Fix confirmed with up2date-2.9.46-1.


Note You need to log in before you can comment on or make changes to this bug.