Bug 679987 - group config history not implemented in gwt
group config history not implemented in gwt
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.B02
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Corey Welton
:
Depends On:
Blocks: jon3
  Show dependency treegraph
 
Reported: 2011-02-23 21:25 EST by John Mazzitelli
Modified: 2011-05-23 21:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2011-02-23 21:25:34 EST
the group configuration history tab is still jsf.

we need to convert to gwt - we can cut-n-paste alot of the resource config history view classes to get a head start.

currently, the resource config history table has a "update type" column - if its a config history that was a child of a group config history, it links to this group config history tab. Because of the JSF limitations, we can't link directly to the specific group history item, we can only link to the group history table as a whole. converting group history view to gwt can solve this problem.
Comment 1 John Mazzitelli 2011-03-01 18:18:25 EST
commit 239280baebbfa542c60cc6430ae526150ab84398

essentially copied the group plugin ui classes and converted the group plugin config server calls to group resource plugin server calls.

made the ui lists and views consistent across individual resource/plugin config views and group resource/plugin config views
Comment 2 Mike Foley 2011-04-26 09:11:10 EDT
group config history is implemented in gwt ....  RHQ 4.0 CR1
Comment 3 Corey Welton 2011-05-23 21:17:23 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 4 Corey Welton 2011-05-23 21:17:23 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:17:23 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:17:26 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.