Bug 679989 - bind dies on USR1 signal (SIGUSR1)
bind dies on USR1 signal (SIGUSR1)
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
14
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-23 21:33 EST by vince
Modified: 2013-04-30 19:48 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-24 08:24:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description vince 2011-02-23 21:33:34 EST
Description of problem:
Sending bind a USR1 or USR2 signal (to increase/decrease debug output) kills it instead

Version-Release number of selected component (if applicable):
9.7.2-5.P3

How reproducible:
every time

Steps to Reproduce:
1. Run bind
2. killall -USR1 bind
  
Actual results:
bind dies

Expected results:
bind should increase debug level by +1

Additional info:
Comment 1 Adam Tkac 2011-02-24 04:53:35 EST
This doesn't seem like a bug for me. Per named(8) manual page:

...
SIGNALS
       In routine operation, signals should not be used to control the nameserver; rndc should be used instead.

       SIGHUP
           Force a reload of the server.

       SIGINT, SIGTERM
           Shut down the server.

       The result of sending any other signals to the server is undefined.
...

May I ask you where did you find SIGUSR1/SIGUSR2 signals should increase/decrease debug output? `rndc trace` should be used instead.
Comment 2 vince 2011-02-24 07:17:37 EST
Shoot, I'm showing my age here. Older named versions used SIGUSR1/SIGUSR2 to do the rndc trace function.

Should the server die when receiving any other signal than the three defined? Seems like it should just ignore them instead.

So, yeah, not a bug in that it's not supposed to do a debug change, but maybe it should ignore the signal altogether instead of die.
Comment 3 Adam Tkac 2011-02-24 08:24:34 EST
(In reply to comment #2)
> Shoot, I'm showing my age here. Older named versions used SIGUSR1/SIGUSR2 to do
> the rndc trace function.
> 
> Should the server die when receiving any other signal than the three defined?
> Seems like it should just ignore them instead.

Well, other signals use their default signal handlers. SIGUSR* default handler is to terminate the running process (check `man 7 signal`) so they do what is expected.

Closing as notabug.

Note You need to log in before you can comment on or make changes to this bug.