Bug 679999 - Fix NUMA problems in transparent hugepages
Fix NUMA problems in transparent hugepages
Status: CLOSED DUPLICATE of bug 688410
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.1
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Andrea Arcangeli
Red Hat Kernel QE team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-23 22:30 EST by CAI Qian
Modified: 2013-01-09 18:35 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-19 11:55:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description CAI Qian 2011-02-23 22:30:18 EST
Description of problem:
http://marc.info/?l=linux-mm&m=129842655126639&w=2

Per developer:

"patch 1 I for sure. The rest I'm unsure yet. I'm unconvinced following
prev page is better than vma (definitely it was wrong for KSM and in
fact Andi dropped that patch already). Anyway Andi knows NUMA
best. We'll see. Last patch I'm unsure if we can include it until it's
upstream because it becomes API visible.

In some ways we've the same problem with the smaps new line, we've to
wait it to hit mainline before showing the smaps, but that's a minor
issue, and we already showed the anonpages in /proc/meminfo (it got
merged upstream so no problem, but usually apps shouldn't break
because of a newline)."
Comment 1 Andrea Arcangeli 2011-04-19 11:55:22 EDT

*** This bug has been marked as a duplicate of bug 688410 ***

Note You need to log in before you can comment on or make changes to this bug.