Bug 68 - CHROOT does not find files
Summary: CHROOT does not find files
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bind   
(Show other bugs)
Version: 5.2
Hardware: i386 Linux
high
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-14 18:18 UTC by Adam Gibson
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1998-11-16 13:49:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Gibson 1998-11-14 18:18:54 UTC
I have had bind 8.1.2 running chrooted to /ch-root/named/
as the user "dnsserv" on an old 5.0 installation with this
command:

"daemon /ch-root/named/usr/sbin/named -u dnsserv -g dnsserv
-t /ch-root/named"

This setup works fine on 5.0. When i have the same setup on
a 5.2 system it starts named and it answers queries, but
named is unable to execute the named-xfer file when needed.
The whole /ch-root/named dir,all files,dirs,subdirs are
chowned dnsserv:dnsserv.

"named[5397]: can't exec /usr/sbin/named-xfer: No such file
or directory"

I went a step further and copied ls into "/ch-
root/named/usr/sbin/ls" and tried these simple test
commands which worked on 5.0 to see if chroot worked 100%,
which failed with the same message.

[root@mirage named]# cd /ch-root/named
[root@mirage named]# chroot /ch-root/named/ ./usr/sbin/ls
chroot: cannot execute ./usr/sbin/ls: No such file or
directory

This same setup works fine with RedHat 5.0. Why would
chroot behave differently under 5.2? The version of chroot
is same same on both machines(1.16).

I have tried everything i can think of. Any any would be
appreciated.

Adam L. Gibson
StatiC@TampaBay.RR.com

Comment 1 Adam Gibson 1998-11-14 22:24:59 UTC
Im sorry to waste anyones time. The problem was i did not create the
two symlinks in the /ch-root/named/lib directory that named/named-
xfer needed.

Adam L. Gibson
StatiC@TampaBay.RR.com

Comment 2 Preston Brown 1998-11-16 13:49:59 UTC
Closed because customer acknowledged user error


Note You need to log in before you can comment on or make changes to this bug.