Bug 680 - Bug in lilo setup when multiple Dos partitions exist
Bug in lilo setup when multiple Dos partitions exist
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
5.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-01-03 22:12 EST by dave
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-11 11:52:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dave 1999-01-03 22:12:28 EST
When installing Redhat Linux 5.2 onto a machine with
multiple DOS partitions (common nowadays due to
manufacturers setting up PCS with multiple Windoze
partitions on the 8+ Gig drives).

When the installer attempts to install lilo, it mistakenly
creates two entries for DOS partitions, but fails to give
the user the option to name the  NON boot one, and will
always fail.  The only way I have found around this is to
manually edit the lilo.conf that the 5.2 installer creates,
and remove the improper entry, and to rerun lilo.  It
appears the installer notices the multiple Dos partitions
but only assigns a name to the bootable one, Peraps a check
to see which partitions have a bootable flag is missing.
This bug only seems to exist when more than 1 DOS or Fat32
partitions exist.
Comment 1 David Lawrence 1999-01-04 15:07:59 EST
Please send us a email containing a dump of your partition
information. Preferredby exactly what shows up when you use the 'p'
command in fdisk. This will help use determine what may be causing the
problem.
Comment 2 David Lawrence 1999-03-11 11:41:59 EST
Close due to lack of response. It may be reopened if needed.

Note You need to log in before you can comment on or make changes to this bug.