Bug 68002 - Evolution requires /etc/ld.so.conf entry to be able to use SSL
Summary: Evolution requires /etc/ld.so.conf entry to be able to use SSL
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: mozilla   
(Show other bugs)
Version: limbo
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Blizzard
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-05 07:31 UTC by Nathan G. Grennan
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-06 18:34:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nathan G. Grennan 2002-07-05 07:31:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020625

Description of problem:
Evolution requires /usr/lib/mozilla-1.0.1 to be added to /etc/ld.so.conf and
ldconfig run to be able to open a SSL connection. Otherwise when trying to make
a connection to a server it just sittings there forever.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Evolution
2. Run Evolution
3. Setup an imap server and set SSL
4. Try to connect to server
	

Actual Results:  Evolution appears to try to connect but spins it's wheel's forever.

Expected Results:  Evolution to connect and messages from the server to be readable.

Additional info:

This problem started with the upgrade to Mozilla 1.0 and switching from
/usr/lib/mozilla to /usr/lib/mozilla-1.0.x

Comment 1 Jeremy Katz 2002-07-06 17:18:22 UTC
No, the mozilla 1.0.1 packages move the nss and nspr libs back into /usr/lib
just for this reason and my fresh limbo install is working just fine.  You do
just have the evolution and mozilla packages from limbo installed, correct? 

If so, from a terminal if you run `CAMEL_VERBOSE_DEBUG=1 evolution-mail`, wait
five seconds, and then start evolution from another terminal, what do you see in
the first terminal when it hangs?

Comment 2 Nathan G. Grennan 2002-07-06 18:24:46 UTC
  I had been Evolution 1.0.8-1(custom build) and Mozilla 1.0.1-5(custom build
with extra patches), but was using standard Limbo packages when I had the
problem. So I did a  rpm -e evolution galeon `rpm -qa | grep -i mozilla`  and
then installed the standard Limbo packages after mounting the iso images via
loopback. I had removed /usr/lib/mozilla-1.0.1 from /etc/ld.so.conf, run
ldconfig, and rebooted before returning to the standard packages. When I started
evolution, for whatever reason, this time it worked just fine. I am pretty sure
I restarted evolution multiple times before and it didn't work till I added the
/etc/ld.so.conf entry, but it doesn't seem to be required now. I can't explain
it. Feel free to close this bug :\

  I did look into the mozilla packages, both the standard and my own, and found
all the libraries had been moved back to /usr/lib except for
/usr/lib/mozilla-1.0.1/libnssckbi.so   I know you might have a reason for
leaving it there, but I thought I would point it out just in case.


Comment 3 Jeremy Katz 2002-07-06 18:34:17 UTC
Don't know about libnssckbi -- Chris?

Comment 4 Christopher Blizzard 2002-07-06 19:29:45 UTC
Fixed in 1.0.1-5 which is in the tree now.

Comment 5 Nathan G. Grennan 2002-07-06 20:20:58 UTC
Do you mean 1.0.1-6? I am currently using a custom compile of 1.0.1-5 and have
been since yesterday and it still has it in /usr/lib/mozilla-1.0.1

[root@cygnusx-1 ~]# rpm -ql mozilla-nss-1.0.1-5
/usr/lib/libnss3.so
/usr/lib/libnssckbi.so
/usr/lib/libsmime3.so
/usr/lib/libsoftokn3.so
/usr/lib/libssl3.so
/usr/lib/mozilla-1.0.1/libnssckbi.so

Comment 6 Christopher Blizzard 2002-07-07 17:25:17 UTC
Look at your output.  It's in both (on purpose, I might add.)


Note You need to log in before you can comment on or make changes to this bug.