Bug 680097 - Can not connect to hidden wireless network with WPA2
Can not connect to hidden wireless network with WPA2
Status: CLOSED DUPLICATE of bug 707434
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
14
i386 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-24 05:54 EST by Akos Ladanyi
Modified: 2012-02-11 05:34 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-11 05:34:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Akos Ladanyi 2011-02-24 05:54:08 EST
Description of problem:
When connection to a hidden wireless network using NetworkManager which is protected by WPA2-Personal the connection fails. This is not the case when using Windows with the same hardware.

Driver:
iwlagn (2.6.35.11-83.fc14.i686.PAE)

Hardware:
Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection

Version-Release number of selected component (if applicable):
Name        : NetworkManager
Arch        : i686
Epoch       : 1
Version     : 0.8.1
Release     : 10.git20100831.fc14

Name        : wpa_supplicant
Arch        : i686
Epoch       : 1
Version     : 0.6.8
Release     : 10.fc14

Log:
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Activation (wlan0) starting connection 'RED'
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> (wlan0): device state change: 3 -> 4 (reason 0)
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> (wlan0): device state change: 4 -> 5 (reason 0)
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Activation (wlan0/wireless): access point 'RED' has security, but secrets are required.
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> (wlan0): device state change: 5 -> 6 (reason 0)
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) scheduled...
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) started...
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> (wlan0): device state change: 6 -> 4 (reason 0)
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) scheduled...
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Activation (wlan0) Stage 1 of 5 (Device Prepare) complete.
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) starting...
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> (wlan0): device state change: 4 -> 5 (reason 0)
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Activation (wlan0/wireless): connection 'RED' has security, and secrets exist.  No new secrets needed.
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Config: added 'ssid' value 'RED'
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Config: added 'scan_ssid' value '1'
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Config: added 'psk' value '<omitted>'
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Activation (wlan0) Stage 2 of 5 (Device Configure) complete.
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> Config: set interface ap_scan to 1
Feb 24 11:52:00 zeratul NetworkManager[1536]: <info> (wlan0): supplicant connection state:  disconnected -> scanning
Feb 24 11:52:26 zeratul NetworkManager[1536]: <warn> Activation (wlan0/wireless): association took too long.
Feb 24 11:52:26 zeratul NetworkManager[1536]: <info> (wlan0): device state change: 5 -> 6 (reason 0)
Feb 24 11:52:26 zeratul NetworkManager[1536]: <warn> Activation (wlan0/wireless): asking for new secrets
Feb 24 11:52:26 zeratul NetworkManager[1536]: <info> (wlan0): supplicant connection state:  scanning -> disconnected
Feb 24 11:52:28 zeratul NetworkManager[1536]: <info> (wlan0): device state change: 6 -> 9 (reason 7)
Feb 24 11:52:28 zeratul NetworkManager[1536]: <warn> Activation (wlan0) failed for access point (RED)
Feb 24 11:52:28 zeratul NetworkManager[1536]: <info> Marking connection 'RED' invalid.
Feb 24 11:52:28 zeratul NetworkManager[1536]: <warn> Activation (wlan0) failed.
Feb 24 11:52:28 zeratul NetworkManager[1536]: <info> (wlan0): device state change: 9 -> 3 (reason 0)
Feb 24 11:52:28 zeratul NetworkManager[1536]: <info> (wlan0): deactivating device (reason: 0).
Comment 1 Jirka Klimes 2011-06-06 04:16:07 EDT
Either the password is wrong or there's another problem in association with AP.
Please switch debugging in wpa_supplicant on and grab /var/log/wpa_supplicant.log

http://live.gnome.org/NetworkManager/Debugging
section "Debugging wpa_supplicant 0.6 and earlier"
Comment 2 Marius Andreiana 2012-02-11 05:34:46 EST
lthough newer, bug #707434 has more info

*** This bug has been marked as a duplicate of bug 707434 ***

Note You need to log in before you can comment on or make changes to this bug.