This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 680120 - Xorg crashes with -vga qxl
Xorg crashes with -vga qxl
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-drv-qxl (Show other bugs)
6.1
Unspecified Linux
urgent Severity urgent
: rc
: ---
Assigned To: Søren Sandmann Pedersen
Desktop QE
: Regression, TestBlocker, Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-24 07:20 EST by Lubos Kocman
Modified: 2014-06-18 05:14 EDT (History)
8 users (show)

See Also:
Fixed In Version: xorg-x11-drv-qxl-0.0.12-6.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-19 10:23:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
switching to console after crash. (16.47 KB, image/png)
2011-02-24 09:13 EST, Lubos Kocman
no flags Details
backtrace of crashing Xorg (3.03 KB, text/plain)
2011-03-17 13:20 EDT, Marian Krcmarik
no flags Details
Xorg.log (49.30 KB, text/plain)
2011-03-17 13:21 EDT, Marian Krcmarik
no flags Details
Xorg -configure (1.79 KB, text/plain)
2011-03-18 17:47 EDT, Marian Krcmarik
no flags Details

  None (edit)
Description Lubos Kocman 2011-02-24 07:20:55 EST
Description of problem:


Run RHEL6.1 guest in qemu-kvm with -vga qxl. Xorg will crash and restart itself in less than 10 seconds.


Version-Release number of selected component (if applicable):

qemu-kvm-0.12.1.2-2.147.el6.x86_64
spice-server-0.7.2-4.el6.x86_64


How reproducible:


Steps to Reproduce:
1. qemu-kvm -vga qxl -spice port=3001,disable-ticketing -m 1024 /yourguest
2. spicec -h localhost -p 3001
3. login to gdm
4. run few applications like soffice, firefox, gnome-system-monitor
  
Actual results:

Xorg crashes in 10-20 seconds after X startup

Expected results:

Xorg won't crash

Additional info:

It does happen with -spice ... -vga qxl and guest driver {qxl,vesa}

(Xorg will not even start with vesa ... could be a separate bug ...)

It does not happen -spice port=3001,... (but without -vga qxl)
It does not happen with vnc
Comment 3 Lubos Kocman 2011-02-24 09:13:21 EST
Created attachment 480767 [details]
switching to console after crash.
Comment 4 Lubos Kocman 2011-02-24 09:13:45 EST
Switching to console after the crash cause lots of defects on the canvas
Comment 5 David Jaša 2011-03-04 10:34:46 EST
Just before this crash, when I typed arrow up into gnome-terminal, the terminal printed "A", then it printed "B" for arrow down.
Comment 6 Alon Levy 2011-03-07 07:18:53 EST
What's the qxl version in the guest? package xorg-x11-drv-qxl.
What is in /var/log/Xorg.0.log?
Comment 7 Uri Lublin 2011-03-16 12:15:44 EDT
We are not sure if that bug is a duplicate of #678208 or a bug on its own.
We asked QE to test if they can reproduce this bug with the fix (scratch build) for 678208.
Comment 8 Marian Krcmarik 2011-03-16 15:02:50 EDT
(In reply to comment #7)
> We are not sure if that bug is a duplicate of #678208 or a bug on its own.
> We asked QE to test if they can reproduce this bug with the fix (scratch build)
> for 678208.

We (QE) consider this to be a bug and not a duplicate of #678208. Two of us tested for several hours with scratch build for qemu-kvm and Xorg crash appears quite often while we haven't got the hang reported in 678208 at all.
Tried 3 different RHEL6.1 64/32bit guests and all the same - seen Xorg crash and no hang of qemu-kvm.

Moreover I tried uri's scratch build of qxl https://brewweb.devel.redhat.com/taskinfo?taskID=3175820 and unfortunately I still get Xorg crash on RHEL6.1 32/64 bit.
Comment 9 Uri Lublin 2011-03-17 08:24:51 EDT
Note that according to https://bugzilla.redhat.com/show_bug.cgi?id=678208#c12
there exists a workaround: 
yum downgrade to xorg-x11-drv-qxl-0.0.12-2.1
Comment 11 Søren Sandmann Pedersen 2011-03-17 10:50:58 EDT
Please try this:

- log in to the guest remotely

- Run   gdb --pid <pid of X server>

- Get X to crash

- Type  bt   into gdb.

Also, as Alon said, please attach the log file, /var/log/Xorg.0.log produced by a crashing X server.
Comment 12 Marian Krcmarik 2011-03-17 13:20:50 EDT
Created attachment 486069 [details]
backtrace of crashing Xorg
Comment 13 Marian Krcmarik 2011-03-17 13:21:21 EDT
Created attachment 486070 [details]
Xorg.log
Comment 14 Marian Krcmarik 2011-03-17 13:22:03 EDT
Attached Xorg.log and bt (hopefully) above.
Comment 15 Søren Sandmann Pedersen 2011-03-17 15:40:10 EDT
      Bad bpp: 1 (1)
      Zero width or height
      Bad bpp: 1 (1)
   Out of memory allocating 16384020 bytes
   Out of mem - stats

As I have mentioned before, we need to increase the amount of video memory available to the qxl device ; otherwise, it will sometimes do this.

I believe the command line option that should be given to qemu is something like this:

     -global qxl.vram_size=268435456
Comment 16 Søren Sandmann Pedersen 2011-03-18 13:23:59 EDT
Can you attach your xorg.conf please?
Comment 17 Marian Krcmarik 2011-03-18 17:46:41 EDT
(In reply to comment #16)
> Can you attach your xorg.conf please?

In case the question is related to my configuration I attach Xorg -configure. Otherwise I use built-in configuration.
Comment 18 Marian Krcmarik 2011-03-18 17:47:44 EDT
Created attachment 486328 [details]
Xorg -configure
Comment 19 Søren Sandmann Pedersen 2011-03-20 13:20:17 EDT
Fixed in 0.0.12-6.el6
Comment 23 errata-xmlrpc 2011-05-19 10:23:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0756.html

Note You need to log in before you can comment on or make changes to this bug.