This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 680132 - QA:Testcase_intelvideo_restartx fails on Acer Aspire netbook
QA:Testcase_intelvideo_restartx fails on Acer Aspire netbook
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
15
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-24 07:57 EST by Stephen Gordon
Modified: 2011-11-22 10:40 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-22 10:40:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Smolt output. (2.48 KB, text/plain)
2011-02-24 07:58 EST, Stephen Gordon
no flags Details
dmesg (64.24 KB, text/plain)
2011-02-24 07:58 EST, Stephen Gordon
no flags Details
Image of white rectangle (662.89 KB, image/jpeg)
2011-02-25 06:28 EST, Rob Whalley
no flags Details

  None (edit)
Description Stephen Gordon 2011-02-24 07:57:21 EST
Description of problem:

Performing the restartx test during Fedora graphics test week (http://fedoraproject.org/wiki/QA:Testcase_intelvideo_restartx) I found that I was unable to successfully boot to init 3 while rhgb remained enabled.

Attempting to boot to init 3 with rhgb enabled resulted in a large white rectangle appearing over the top left of the screen, no further feedback was displayed. Re-attempting after removing the rhgb parameter did allow me to boot to init 3.

Version-Release number of selected component (if applicable):

F15 graphics test week image.

How reproducible:

Every time.

Steps to Reproduce:
1. Boot graphics test week image.
2. At grub prompt edit boot params adding '3' to set the init level.
3. Boot this configuration.
  
Actual results:

Machine booted at init level 3. Login prompt for displayed.

Expected results:

White rectangle artifact. No further feedback.

Additional info:

Attachments to follow.
Comment 1 Stephen Gordon 2011-02-24 07:58:02 EST
Created attachment 480745 [details]
Smolt output.
Comment 2 Stephen Gordon 2011-02-24 07:58:34 EST
Created attachment 480746 [details]
dmesg
Comment 3 Rob Whalley 2011-02-25 06:26:27 EST
Also noted white rectangle artefact during testing using test day live CD on a Samsung NC10 netbook (external USB DVD-RW):
http://www.smolts.org/client/show/pub_6addbf83-d0f4-47c5-8219-d88d2c00e5aa

I've attached a basic camera phone picture to help illustrate this, hopefully this is the same issue that is noted above. Apologies for the poor picture quality.
Comment 4 Rob Whalley 2011-02-25 06:28:12 EST
Created attachment 480969 [details]
Image of white rectangle
Comment 5 Matěj Cepl 2011-02-25 08:30:20 EST
Thanks for the bug report.  We have reviewed the information you have provided above, and there is some additional information we require (from BOTH of you) that will be helpful in our diagnosis of this issue.

Please add drm.debug=0x04 to the kernel command line, restart computer, and attach

* your X server config file (/etc/X11/xorg.conf, if available),
* X server log file (/var/log/Xorg.*.log)
* output of the dmesg command, and
* system log (/var/log/messages)

to the bug report as individual uncompressed file attachments using the bugzilla file attachment link above.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 6 Stephen Gordon 2011-03-22 08:35:11 EDT
Apologies for the delay on this but when I add drm.debug=0x04 the netbook in question seems to take an inordinate amount of time to boot, to the point that I give up on it. Is it expected to extend boot time? How I can I check what if anything is happening?

It starts the graphical boot ok and then the progress indicator seems to complete but at that point nothing further happens. Am now working with the F15 alpha rather than the gfx test day image.
Comment 7 Matěj Cepl 2011-03-23 06:39:21 EDT
(In reply to comment #6)
> Apologies for the delay on this but when I add drm.debug=0x04 the netbook in
> question seems to take an inordinate amount of time to boot, to the point that
> I give up on it. Is it expected to extend boot time? How I can I check what if
> anything is happening?

Yes, but you shouldn't almost recognize the delay. Logs withouht that drm.debug are useful as well, so if you cannot help it, don't sweat it and provide them without drm.debug.

> It starts the graphical boot ok and then the progress indicator seems to
> complete but at that point nothing further happens. Am now working with the F15
> alpha rather than the gfx test day image.

Yes, that's correct. There are still many bugs being fixed as days go by.
Comment 8 Rob Whalley 2011-04-20 04:28:39 EDT
Since installing the beta version of F15 released 19/04/2011, this issue
appears to be fixed for me.
Comment 9 Stephen Gordon 2011-11-22 10:40:53 EST
Agree with the above poster, this works on my netbook now also. As the original reporter I am closing this bug.

Note You need to log in before you can comment on or make changes to this bug.