Bug 680164 - error in group>inventory>conn settings if still in progress
error in group>inventory>conn settings if still in progress
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.0.0.B02
Unspecified Unspecified
medium Severity medium (vote)
: ---
: ---
Assigned To: John Mazzitelli
Corey Welton
:
Depends On:
Blocks: jon3
  Show dependency treegraph
 
Reported: 2011-02-24 09:15 EST by John Mazzitelli
Modified: 2011-05-23 21:16 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Mazzitelli 2011-02-24 09:15:19 EST
my agent was down.
I had a group with that agent in it.
I edited that group's conn props
After I hit save, I got an error:

Failed to retrieve member connection settings for [ResourceGroup[id=10051, name=agents, category=COMPATIBLE, type=RHQ Agent, isDynaGroup=false, isClusterGroup=false]]

java.lang.RuntimeException:org.rhq.enterprise.server.configuration.ConfigurationUpdateStillInProgressException:Current group plugin configuration for ResourceGroup[id=10051, name=agents, category=COMPATIBLE, type=RHQ Agent, isDynaGroup=false, isClusterGroup=false] cannot be calculated, because a group plugin configuration update is currently in progress.

We should catch that and post a more friendly reminder that "you can't view the current config because a update is currently in progress).
Comment 1 John Mazzitelli 2011-02-28 11:10:01 EST
commit 9733f31

there is now a info message that asks that you wait until the update finishes.

you can't view group update settings if there is a current update in progress.
Comment 2 Mike Foley 2011-04-25 11:09:53 EDT
this is verified in RHQ 4.0 CR1 release.  I updated a group's connection information and observed the info message described above.  i was unable to update the connection information a 2nd time while the 1st update was in progress, which is the new excpected behavior.
Comment 3 Corey Welton 2011-05-23 21:16:13 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 4 Corey Welton 2011-05-23 21:16:25 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 5 Corey Welton 2011-05-23 21:16:26 EDT
Bookkeeping - closing bug - fixed in recent release.
Comment 6 Corey Welton 2011-05-23 21:16:30 EDT
Bookkeeping - closing bug - fixed in recent release.

Note You need to log in before you can comment on or make changes to this bug.