Bug 680175 - Please add EL5 package build
Summary: Please add EL5 package build
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: gitolite
Version: el5
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-24 14:45 UTC by Gianluca Sforna
Modified: 2012-09-13 19:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-09-13 19:06:05 UTC


Attachments (Terms of Use)

Description Gianluca Sforna 2011-02-24 14:45:04 UTC
I am installing a git server at the office and just realized gitolite is not available in EL5.

However, I can see the corresponding branch in the Fedora git repo so I wonder if there is any reason why the build was not done and pushed.

Thanks in advance

Comment 1 Lubomir Rintel 2011-02-24 15:46:16 UTC
That is because I suck. I had it in corporate repository and thus somehow did not notice it missing in EPEL...

Built here, please give it a try:
https://admin.fedoraproject.org/updates/gitolite-1.5.9.1-1.el5.1

Karma it up if it works for you, it will be then pushed into stable after some time in testing.

Thank you!

Comment 2 extremoburo 2011-02-25 14:27:01 UTC
Testing on CentOS 5.4:

[root@gitserver ~]# rpm -qa | grep git
gitolite-1.5.9.1-1.el5.1
git-1.7.4.1-1.el5

I've got this error:

-sh-3.2$ gl-setup /tmp/mykey.pub 
cp: cannot stat `/usr/local/share/gitolite/conf/example.gitolite.rc': No such file or directory
The default settings in the rc file (/var/lib/gitolite/.gitolite.rc) are fine for most
people but if you wish to make any changes, you can do so now.

hit enter...
error parsing /var/lib/gitolite/.gitolite.rc
Compilation failed in require at /usr/local/bin/gl-query-rc line 17.
error parsing /var/lib/gitolite/.gitolite.rc
Compilation failed in require at /usr/local/bin/gl-query-rc line 17.
error parsing /var/lib/gitolite/.gitolite.rc
Compilation failed in require at /usr/local/bin/gl-query-rc line 17.
ENV GL_BINDIR not set
BEGIN failed--compilation aborted at /usr/local/bin/gl-install line 15.
/usr/local/bin/gl-setup: line 113: /conf/gitolite.conf: No such file or directory
cp: cannot create regular file `/keydir': Permission denied
ENV GL_BINDIR not set
BEGIN failed--compilation aborted at /usr/local/bin/gl-compile-conf line 16.
/usr/local/bin/gl-setup: line 128: cd: /gitolite-admin.git: No such file or directory
fatal: Not a git repository (or any of the parent directories): .git
fatal: Not a git repository (or any of the parent directories): .git
ENV GL_BINDIR not set
BEGIN failed--compilation aborted at /usr/local/bin/gl-install line 15.
-sh-3.2$

It should be looking for /usr/share/gitolite/conf/example.gitolite.rc instead. 
I copied it in /usr/local/share/gitolite/conf/ and had another run. I got this message:

-sh-3.2$ gl-setup /tmp/mykey.pub 
cp: cannot stat `/usr/local/bin/../doc': No such file or directory
cp: cannot stat `/usr/local/bin/../hooks': No such file or directory
cp: cannot stat `/usr/local/bin/../conf/VERSION': No such file or directory
creating gitolite-admin...
Initialized empty Git repository in /var/lib/gitolite/repositories/gitolite-admin.git/
creating testing...
Initialized empty Git repository in /var/lib/gitolite/repositories/testing.git/
[master (root-commit) 2997c22] start
 Committer: git repository hosting <gitolite@gitserver.local>
Your name and email address were configured automatically based
on your username and hostname. Please check that they are accurate.
You can suppress this message by setting them explicitly:

    git config --global user.name "Your Name"
    git config --global user.email you@example.com

After doing this, you may fix the identity used for this commit with:

    git commit --amend --reset-author

 2 files changed, 7 insertions(+), 0 deletions(-)
 create mode 100644 conf/gitolite.conf
 create mode 100644 keydir/fabrizio.pub
cp: cannot stat `/usr/local/bin/../doc': No such file or directory
cp: cannot stat `/usr/local/bin/../hooks': No such file or directory
cp: cannot stat `/usr/local/bin/../conf/VERSION': No such file or directory

still can't give a karma up tough I'm really after that ;)

Comment 3 Lubomir Rintel 2011-02-25 14:52:32 UTC
I'll take a look.

Meanwhile, could you please verify that documented way to set up gitolite from the package works? See /usr/share/doc/gitolite-1.5.9.1/gitolite-README-fedora

Comment 4 extremoburo 2011-02-25 15:30:19 UTC
I did exactly what suggested in /usr/share/doc/gitolite-1.5.9.1/gitolite-README-fedora .

Comment 5 Gwyn Ciesla 2011-07-17 18:02:26 UTC
Lubo, since this is still in testing, and I'm fixing 2.0.2 in rawhide for a lot of things, any objections to my pushing that to all stable Fedora and EPEL branches if 713020 is fixed?

Comment 6 Julian C. Dunn 2012-08-28 21:06:52 UTC
Is there any movement on this? I would love to see gitolite 2.x or 3.x built for EPEL5 and can help out if needed.

Comment 7 Gwyn Ciesla 2012-08-28 21:26:12 UTC
Do you have a preference, 2 or 3?

Comment 8 Julian C. Dunn 2012-08-28 21:36:27 UTC
2 would be enough for me right now.

Comment 9 Gwyn Ciesla 2012-08-29 15:02:15 UTC
Ok, updating gitolite to 2.3 in el5.

Comment 10 Fedora Update System 2012-08-29 15:10:52 UTC
gitolite-2.3.1-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/gitolite-2.3.1-1.el5

Comment 11 Fedora Update System 2012-08-30 05:06:25 UTC
Package gitolite-2.3.1-1.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing gitolite-2.3.1-1.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-12769/gitolite-2.3.1-1.el5
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2012-09-13 19:06:05 UTC
gitolite-2.3.1-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.