Bug 68022 - Printing from Kate, hpijs print driver misses first line
Printing from Kate, hpijs print driver misses first line
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: ghostscript (Show other bugs)
limbo
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-07-05 09:19 EDT by Gerry Tool
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-12 13:45:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Atatachemnt requested by assigned troubleshooter (178 bytes, application/octet-stream)
2002-08-09 23:45 EDT, Gerry Tool
no flags Details
Attachment of local.adl when printer is connected directly to computer (178 bytes, application/octet-stream)
2002-08-10 09:13 EDT, Gerry Tool
no flags Details
config file downloaded via ftp from hardware netgear printserver (1.36 KB, text/plain)
2002-08-12 10:30 EDT, Gerry Tool
no flags Details

  None (edit)
Description Gerry Tool 2002-07-05 09:19:22 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020625

Description of problem:
Printing from Kate, the first line is missing when using the hpijs printer
driver under cups on a HP Deskjet 970C.  The hpdj970 driver prints all lines as
expected.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.create a page using Kate
2.select a printer and print the page
3.
	

Actual Results:  With hpijs driver, first line of page is not printed.
With hpdj970 driver, all lines are printed.

Expected Results:  All lines on page should be printed.

Additional info:
Comment 1 Tim Waugh 2002-07-08 05:46:20 EDT
Does the test page from printtool look as it should?
Comment 2 Gerry Tool 2002-07-08 09:12:19 EDT
Tried to print test page from printtool.  Since I'm using cups, this printer
does not appear in printtool.  Tried to print test page from KDE Control Panel >
Cups Printer Configuration.  Get error: "client-error-not-possible".  Tried to
print test page from KDE Control Center > System > Printing Manager.  Test page
printed succussfully with all elements showing on page.  Gerry Tool
Comment 3 Tim Waugh 2002-07-08 09:15:28 EDT
Is it just kate that shows this behaviour or all KDE applications?
Comment 4 Tim Waugh 2002-07-18 04:39:47 EDT
*ping*
Comment 5 Gerry Tool 2002-07-18 08:42:01 EDT
The first line is missing when printing with hpijs from kate and kwrite, but is
present when printing from kedit and kword.
Comment 6 Gerry Tool 2002-07-30 16:05:28 EDT
this bug is still present in limbo beta 2
Comment 7 Tim Waugh 2002-08-08 12:33:39 EDT
I can't reproduce this problem using LPRng.  I tried an HP DeskJet 970Cxi.  
The first line comes out fine. 
 
Will try CUPS.
Comment 8 Tim Waugh 2002-08-08 13:39:49 EDT
Works fine in CUPS too.  Perhaps your page size setting is wrong?
Comment 9 Gerry Tool 2002-08-08 14:04:15 EDT
This bug still exists on my system which has all limbo2 updates applied.  Make
afile in kate that has a few distinct lines.  Print it with hpijs using cups and
the first line will not be on the page - paper size set to US Letter.

Another printer defined with hpdj970 driver prints all four lines just fine.

kwrite has the same behaviour.  kedit and kword print normally.
Comment 10 Tim Waugh 2002-08-08 14:29:51 EDT
If you browse to http://localhost:631/ and configure that printer, does that 
have the right page size? 
 
Also, when you view the properties immediately prior to pressing the 'print' 
button, does that page size agree? 
 
I have tried to reproduce this, and have been unable to.  All the lines 
entered into kate printed out correctly.
Comment 11 Gerry Tool 2002-08-08 20:15:10 EDT
Yes, the CUPS Admin page shows letter size, as does the printer dialog called     
up at printing time.  The printer is attached to a Netgear print server on my     
LAN accessed as a LPD/LPR Host or Printer with lpd://ip-address/queue, using     
the HP Deskjet 970C, Foomatic + hpijs (en) driver.  Two other printer    
definitions using the same setup except using the HP DesKJet 970C, Foomatic +   
cdj970 (en) driver and the  HP DesKJet 970C, Foomatic + gimp-print (en) driver  
always print correctly.   
  
I'm mystified why this doesn't work and yours does.  It's not a critical  
issue for my use since there are other alternatives, but I think it ought to  
work correctly.
Comment 12 Tim Waugh 2002-08-09 10:24:39 EDT
Can you try attaching it locally?
Comment 13 Tim Waugh 2002-08-09 11:44:16 EDT
I had been trying this with A4 paper, since that's what I have access to.  I
just tried this with US Letter, and the result is the same: all lines print
correctly.

It might help if you attach your /etc/alchemist/namespace/printconf/local.adl
file, so that I can see the exact config you are using.
Comment 14 Gerry Tool 2002-08-09 23:45:29 EDT
Created attachment 69827 [details]
Atatachemnt requested by assigned troubleshooter
Comment 15 Gerry Tool 2002-08-10 09:11:37 EDT
I temporarily connected the printer to my computer instead of the network file
server, and sure enough, the first line appears on the page when printing from
kate.  So, the missing line occurs when using the hpijs driver AND kate AND a
networked Netgear print server configured as an LPD/LPR Host or Printer.  I will
next attach the same file I attached previously with the network connection.
Comment 16 Gerry Tool 2002-08-10 09:13:12 EDT
Created attachment 69845 [details]
Attachment of local.adl when printer is connected directly to computer
Comment 17 Tim Waugh 2002-08-12 06:35:44 EDT
How is the print server configured?  Seems like a problem at that end..
Comment 18 Gerry Tool 2002-08-12 10:27:24 EDT
The printserver is a piece of hardware with no real setup.  I will attach a copy
of the CONFIG file downloaded from the printserver next.  However, it it is the
printserver, why does it miss the line with kate and kwrite but not with kedit?
 Also, why does the cdj970 printer driver not miss the line with any of the
apps?   And why does the hpijs server delivered with RH7.3 not miss the line?
Comment 19 Gerry Tool 2002-08-12 10:30:54 EDT
Created attachment 70026 [details]
config file downloaded via ftp from hardware netgear printserver
Comment 20 Gerry Tool 2002-08-12 10:34:36 EDT
I have upgraded via rawhide to cups-1.1.15-5, cups-drivers-1.9-1.20020617.5 (all). 
foomatic-1.9-1.20020617.5 and hpijs-1.1-17. This may make a difference in my
ability to give you proper information.  These upgrades made no difference in
this particular problem.
Comment 21 Tim Waugh 2002-08-12 10:43:02 EDT
The CONFIG file looks meaningless to my untrained eyes.  Hopefully we can set 
up a similar situation without the netgear device: 
 
1. make a RAW queue on the local machine and call it 'raw' 
2. set up another queue for lpd://localhost/raw and call it 'test' 
3. attach the printer locally 
4. print a test page to the 'test' queue 
 
(That should be equivalent to switching the netgear box for a Red Hat Linux 
Limbo lpd server.)
Comment 22 Gerry Tool 2002-08-12 12:37:03 EDT
Could you tell me the details of making the raw queue?  Once that is made, I 
presume I can use the CUPS admin page to set up test.  If not, please tell me 
how to do that also.  Thanks. 
Comment 23 Tim Waugh 2002-08-12 12:55:04 EDT
For step 1 choose the parallel port you will connect it to in the 'device' 
screen, and choose 'raw' for the 'model/driver' screen.
Comment 24 Gerry Tool 2002-08-12 13:36:44 EDT
OK, I set up a queue on Parallel port #1 where I have the HP DeskJet 970  
attached, called it raw, chose model Raw and driver Raw Queue (en).  I then  
set up a queue called test, gave it a port of lpd://localhost/raw, a model of  
HP and the 970 hpijs driver.  I printed to the test queue, and it is hung 
"attempting to connect to host localhost for printer raw".  Localhost is 
obviously working since I'm also in a browser viewing 
http://localhost:631/printers.  I know that raw is working because sending a 
job to it pushes out paper with single command lines on it.  I also tested it 
once using the hpijs driver instead of raw and it printed a page fine.
Comment 25 Gerry Tool 2002-08-12 13:45:15 EDT
the printer "test" is showing: 
 
INFO: Network host 'localhost' is busy; will retry in 30 seconds...INFO: 
Network host 'localhost' is busy; will retry in 30 seconds 
 
repeatedly.
Comment 26 Gerry Tool 2002-08-15 20:30:05 EDT
A fresh install of limbo 2, followed by an up2date cycle and creation of a
networked printer using hpijs resulted in this behaviour not showing up.  The
first line in the Kate output now appears as it should.

Note You need to log in before you can comment on or make changes to this bug.