Bug 680226 - DeviceTreeError: MD RAID device md127 already in devicetree as md0
DeviceTreeError: MD RAID device md127 already in devicetree as md0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
15
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
anaconda_trace_hash:8ea4a37f3e9808d1b...
:
: 660258 (view as bug list)
Depends On:
Blocks: F15Beta/F15BetaBlocker
  Show dependency treegraph
 
Reported: 2011-02-24 13:17 EST by Sandro Mathys
Modified: 2011-03-16 00:06 EDT (History)
6 users (show)

See Also:
Fixed In Version: anaconda-15.22-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-03-16 00:06:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Attached traceback automatically from anaconda. (431.30 KB, text/plain)
2011-02-24 13:17 EST, Sandro Mathys
no flags Details
Attached traceback automatically from anaconda. (1.48 MB, text/plain)
2011-02-28 18:25 EST, Adam Williamson
no flags Details
Patch to improve handling of active fwraid during devicetree populate (3.99 KB, patch)
2011-03-02 12:19 EST, David Lehman
no flags Details | Diff
Patch to improve handling of active fwraid during devicetree populate (4.42 KB, patch)
2011-03-02 12:22 EST, David Lehman
no flags Details | Diff

  None (edit)
Description Sandro Mathys 2011-02-24 13:17:09 EST
The following was filed automatically by anaconda:
anaconda 15.20.1 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 732, in addUdevMDDevice
    "devicetree as %s" % (name, device.name))
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 979, in addUdevDevice
    device = self.addUdevMDDevice(info)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1764, in _populate
    self.addUdevDevice(dev)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 1722, in populate
    self._populate()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 434, in reset
    self.devicetree.populate()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 103, in storageInitialize
    storage.reset()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 211, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/dispatch.py", line 130, in gotoNext
    self.moveStep()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1257, in nextClicked
    self.anaconda.dispatch.gotoNext()
DeviceTreeError: MD RAID device md127 already in devicetree as md0
Comment 1 Sandro Mathys 2011-02-24 13:17:15 EST
Created attachment 480825 [details]
Attached traceback automatically from anaconda.
Comment 2 Sandro Mathys 2011-02-24 13:24:07 EST
Installation on Intel BIOS RAID with LiveCD (alpha RC1 / KDE) not possible, DVD not checked.

This breaks the following test case:
http://fedoraproject.org/wiki/QA:Testcase_Install_to_BIOS_RAID
...as this expected result is not fulfilled:
"All installable BIOS RAID devices are successfully detected by installer and are available for partitioning"

According to
http://fedoraproject.org/wiki/Test_Results:Current_Installation_Test#General_Tests
...that's a beta criterion.

Therefore I'm going to propose this as a beta blocker.
Comment 3 Adam Williamson 2011-02-28 18:25:21 EST
Created attachment 481472 [details]
Attached traceback automatically from anaconda.
Comment 4 Adam Williamson 2011-02-28 18:25:55 EST
like Sandro, I hit this after applying the patch for 678877.
Comment 5 David Lehman 2011-03-02 12:19:12 EST
Created attachment 481913 [details]
Patch to improve handling of active fwraid during devicetree populate

This is related to the fact that dracut has started activating fwraid arrays automatically on livecd startup.
Comment 6 David Lehman 2011-03-02 12:22:22 EST
Created attachment 481914 [details]
Patch to improve handling of active fwraid during devicetree populate
Comment 7 Sandro Mathys 2011-03-02 13:02:23 EST
I can confirm that patch to fix this issue. I then hit bug 681608, though.
Comment 8 Adam Williamson 2011-03-02 13:10:51 EST
it's RAID whack-a-mole, hooray.

dlehman: do we want to stop dracut doing that, for the live boot?
Comment 9 David Lehman 2011-03-03 10:52:16 EST
Patches that (attempt to) fix all known firmware RAID issues for F15 are available in bug 681608 for those doing live installs. For those doing non-live installs, just ask and I'll be happy to provide an updates image for you to test with.

As for dracut assembling the fwraid... it was considered a bug when they were not auto-assembled, so we should probably leave it be now.
Comment 10 David Lehman 2011-03-04 11:10:49 EST
Last patch had a problem. It did not take into account the fact that mdadm will append an underscore and some number of digits to the name of an array it assembles if the system hostname at the time of assembly does not match the hostname in the array metadata. Good stuff.

New patch:

  http://dlehman.fedorapeople.org/fwraid-f15.4.patch

New updates:

  http://dlehman.fedorapeople.org/updates-fwraid-f15.4.img


Please test and let me know the results.
Comment 11 David Lehman 2011-03-08 15:57:08 EST
*** Bug 660258 has been marked as a duplicate of this bug. ***
Comment 12 David Lehman 2011-03-09 14:07:41 EST
Fixed for Fedora 15 in anaconda-15.22-1.
Comment 13 Fedora Update System 2011-03-09 16:55:10 EST
anaconda-15.22-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.22-1.fc15
Comment 14 James Laska 2011-03-11 14:40:48 EST
Discussed at 2011-03-11 blocker review meeting.  This issue is fixed and available for testing in anaconda-15.22-1.  The issue has been accepted as a beta blocker.
Comment 15 Fedora Update System 2011-03-16 00:05:50 EDT
anaconda-15.22-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.