Bug 680385 - The key is not saved anymore after package update
Summary: The key is not saved anymore after package update
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 14
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 680448 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-25 11:52 UTC by Franck Waechter
Modified: 2011-04-12 21:27 UTC (History)
2 users (show)

Fixed In Version: NetworkManager-0.8.3.996-1.fc14
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-02 01:50:01 UTC


Attachments (Terms of Use)
.xsession-errors file after upgrade (and reboot) (4.76 KB, text/plain)
2011-02-25 19:48 UTC, Franck Waechter
no flags Details
/var/log/messages file (extracted just before NetworkManager upgrade) (111.50 KB, text/plain)
2011-02-25 19:53 UTC, Franck Waechter
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 680448 None None None Never

Internal Links: 680448

Description Franck Waechter 2011-02-25 11:52:03 UTC
Description of problem:

The key (WEP) is not saved after the last NetworkManager upgrade (NetworkManager-0.8.3.995-1).
I have to reenter to each login. It was not the case before.

Version-Release number of selected component (if applicable):

It doesn't work with :

NetworkManager-0.8.3.995-1.fc14.x86_64
NetworkManager-glib-0.8.3.995-1.fc14.x86_64
NetworkManager-gnome-0.8.3.995-1.fc14.x86_64

But it works with my previous packages :

NetworkManager-0.8.1-10.git20100831.fc14.x86_64
NetworkManager-glib-0.8.1-10.git20100831.fc14.x86_64
NetworkManager-gnome-0.8.1-10.git20100831.fc14.x86_64

How reproducible:

the key is just lost after reboot

Steps to Reproduce:
1. Set the WEP key to login
2. Restart the machine
3. Login
  
Actual results:

The key is not saved

Expected results:

The key must be saved and autologin should proceed without interruption

Comment 1 Dan Williams 2011-02-25 18:57:57 UTC
Can you provide both /var/log/messages and ~/.xsession-errors so we can debug further?  Thanks!

Also, what version of the "gnome-keyring" package do you have?

Comment 2 Franck Waechter 2011-02-25 19:32:46 UTC
Ok

libgnome-keyring-2.32.0-1.fc14.x86_64
gnome-keyring-2.32.1-1.fc14.x86_64
gnome-keyring-devel-2.32.1-1.fc14.x86_64
libgnome-keyring-devel-2.32.0-1.fc14.x86_64
gnome-keyring-pam-2.32.1-1.fc14.x86_64

I'm watching for logs file.

Comment 3 Franck Waechter 2011-02-25 19:48:10 UTC
Created attachment 481070 [details]
.xsession-errors file after upgrade (and reboot)

This file has been flush just before the upgrade

Comment 4 Franck Waechter 2011-02-25 19:53:18 UTC
Created attachment 481072 [details]
/var/log/messages file (extracted just before NetworkManager upgrade)

My steps :

1. Flush messages (and .xsession-errors) file
2. Upgrade NetworkManager to target version
3. System Restart
4. Login & Set WEP key
5. Logout & Set again WEP key
4. Collect Traces

Comment 5 Dan Williams 2011-02-25 21:43:20 UTC
*** Bug 680448 has been marked as a duplicate of this bug. ***

Comment 6 Dan Williams 2011-02-25 21:45:07 UTC
Thanks, the logs pointed me right to the problem.

Upstream fix is a2739c8e08676b56e3256feb5f4efa535aad7869 (NM_0_8)

Comment 7 Fedora Update System 2011-02-25 23:42:16 UTC
Package NetworkManager-0.8.3.996-1.fc14:
* should fix your issue,
* was pushed to the Fedora 14 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.996-1.fc14'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.996-1.fc14
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2011-02-25 23:45:14 UTC
Package NetworkManager-0.8.3.996-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.996-1.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.996-1.fc13
then log in and leave karma (feedback).

Comment 9 Franck Waechter 2011-02-25 23:54:39 UTC
Done !

It works for me now

Thank you

Comment 10 Fedora Update System 2011-02-26 03:58:20 UTC
NetworkManager-0.8.3.996-1.fc14 has been pushed to the Fedora 14 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update NetworkManager'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.996-1.fc14

Comment 11 J.H.M. Dassen (Ray) 2011-02-26 18:02:56 UTC
(In reply to comment #7)
> Please go to the following url:
> https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.996-1.fc14
> then log in and leave karma (feedback).

As I didn't receive the account registration email I'm unable to complete
registration, so I'm providing my feedback here instead:
with NetworkManager-0.8.3.996-1.fc14.x86_64, things work as expected again:
I'm not being prompted for a known WPA key any more, and connections to the
Red Hat VPN are working fine.

Comment 12 Fedora Update System 2011-03-02 01:48:33 UTC
NetworkManager-0.8.3.996-1.fc14 has been pushed to the Fedora 14 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2011-03-03 09:46:35 UTC
Package NetworkManager-0.8.3.997-1.fc13:
* should fix your issue,
* was pushed to the Fedora 13 updates-testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing NetworkManager-0.8.3.997-1.fc13'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.997-1.fc13
then log in and leave karma (feedback).

Comment 14 Fedora Update System 2011-03-25 03:29:28 UTC
NetworkManager-0.8.3.998-2.fc13 has been submitted as an update for Fedora 13.
https://admin.fedoraproject.org/updates/NetworkManager-0.8.3.998-2.fc13

Comment 15 Fedora Update System 2011-04-12 21:27:20 UTC
NetworkManager-0.8.3.998-2.fc13 has been pushed to the Fedora 13 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.