Bug 6805 - Disk Druid will create more partitions than device allows
Summary: Disk Druid will create more partitions than device allows
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
(Show other bugs)
Version: 6.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-11-07 21:17 UTC by Jason Tibbitts
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-04 16:31:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jason Tibbitts 1999-11-07 21:17:19 UTC
I ran into some issues when installing 6.1 on a machine with
a DAC960-based RAID array.  Using Disk Druid I created a
number of partitions on /dev/rd/c0d0 (/, /boot, /var, /usr,
/usr/local, /home and a swap partition).  Disk Druid made
one primary partition, put /boot on it, and put the rest
inside an extended partition starting at c0d0p5.  More
specifically, / was on c0d0p9.

Unfortunately the minor device allocations for the DAC960
drivers only allow seven partitions per virtual disk, so /
could not even be mounted and the install failed with an
error about not having space on / (as it was trying to do
the install into the ramdisk).

Running in expert mode, using fdisk to avoid wasting two
primary partitions and paring down the list by one was
enough to get everything to fit.

It would be nice if Disk Driud didn't waste those primary
partitions.  It would also be nice if the DAC960 driver
didn't have such a tiny partition limit, but that's not
something I expect you can fix.

Comment 1 Jay Turner 1999-11-09 15:36:59 UTC
This issue has been assigned to a developer for further action.

Comment 2 Michael Fulbright 2000-02-04 16:31:59 UTC
We've made some changes to disk druid to use primary partitions slightly
differently than in the past, but it does not know about the limitations
of the RAID array you have. I would recommend using fdisk since it allows
you inifinte flexibility (at the expense of user friendliness admittedly).


Note You need to log in before you can comment on or make changes to this bug.