Bug 68051 - Anaconda crash on attempt to install Limbo
Anaconda crash on attempt to install Limbo
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: anaconda (Show other bugs)
limbo
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Mike A. Harris
Brock Organ
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-07-05 17:01 EDT by Andy Green
Modified: 2007-03-26 23:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-10 00:22:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda crash dump file (59.25 KB, text/plain)
2002-07-05 17:03 EDT, Andy Green
no flags Details

  None (edit)
Description Andy Green 2002-07-05 17:01:44 EDT
Description of Problem:
Attempt to upgrade Athlon 1900+ machine which had 7.3 installed from clean
results in anaconda crash.  Xilimain Gnome installed.  160GB Maxtor HDD with own
IDE 133 card supplied by Maxtor.  Working fine under 7,3.

During install Anaconda crashes, 
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 682, in ?
    intf.run(id, dispatch, configFileData)
  File "/usr/src/build/121825-i386/install//usr/lib/anaconda/text.py", line 441,
in run
  File "/usr/src/build/121825-i386/install//usr/lib/anaconda/dispatch.py", line
149, in gotoNext
  File "/usr/src/build/121825-i386/install//usr/lib/anaconda/dispatch.py", line
214, in moveStep
  File "/usr/src/build/121825-i386/install//usr/lib/anaconda/packages.py", line
114, in readPackages
  File "/usr/src/build/121825-i386/install//usr/lib/anaconda/harddrive.py", line
176, in readHeaders
  File "/usr/src/build/121825-i386/install//usr/lib/anaconda/harddrive.py", line
114, in mountMedia
  File "/usr/src/build/121825-i386/install//usr/lib/anaconda/harddrive.py", line
152, in mountDirectory
  File "/usr/lib/anaconda/isys.py", line 153, in mount
    rc = _isys.mount(fstype, device, location, readOnly)
SystemError: (16, 'Device or resource busy')

Local variables in innermost frame:
device: /tmp/hde2
readOnly: 1
devName: /tmp/hde2
location: /tmp/isodir
fstype: ext2

[etc]

Version-Release number of selected component (if applicable):

Limbo Installer

How Reproducible:

Fully, cannot install Limbo.

Steps to Reproduce:
1. Reboot with floppy dd'd with boot image
2. Enter appropriate responses to install app
3. Before install begin, watch crash with horror

Actual Results:
Anaconda crash dump

Expected Results:
Install of cool new OS

Additional Information:

From HDD ISO images, in /home/agreen/Desktop.  Only one HDD in machine.
Comment 1 Andy Green 2002-07-05 17:03:31 EDT
Created attachment 63865 [details]
Anaconda crash dump file
Comment 2 Andy Green 2002-07-08 01:14:33 EDT
Some more news.  

1) I made some CDs of the ISOs, but was plagued by media errors. However, before
the first error, on the graphical install, on my Creative Labs Geforce 2 card,
partway through the installation, during the long night of the RPMs, the screen
was permanently corrupted with what appeared to be part of the screen furniture
magnified and overlaid on the video so you couldn't see what was happening.

2) In the end I mounted a second HDD as /dev/hdh, fdisked and mkfs -j -d it and
copied the ISOs to it.  Then I tried again with the boot floppy, selected to
install from /dev/hdh1 and this time was able to install fully.  I saw other bug
reports since then saying the same thing, installing to the partition where the
ISOs are stored in a problem.

Some fantastic stuff in this beta when it gets installed!
Comment 3 Michael Fulbright 2002-07-09 20:12:10 EDT
Sounds like you were having media errors from the CDs, good to hear the HD
install works.

I have no idea about the X bug, reassigning.
Comment 4 Mike A. Harris 2002-07-09 21:10:44 EDT
Please file separate bug reports for each bug you're reporting rather
than clustering multiple bugs into one report.

Please attach your X config file, and X server log to the bug report,
and provide as many details as possible which might be helpful
determining what the problem may be.

Also, I'm not sure what "screen furniture" means.
Comment 5 Andy Green 2002-07-10 00:22:06 EDT
"screen furniture" means the borders around boxes, bitmaps etc.  It was a single
horizontal line of the bitmap, showing gradated shades of brown then the edge of
a window.  The single horizontal line repeated down the screen, making a tower
of it.  It was never overwritten, but there were two thin strips which still
showed the normal progress of the RPM installs.

I take the point about separate bug reports, sorry.
Comment 6 Mike A. Harris 2002-07-19 09:32:43 EDT
Closing bug as anaconda issue is resolved.  Please file new bug report
for XFree86 if still relevant, and include your config file and log file.

Note You need to log in before you can comment on or make changes to this bug.