Bug 680601 - Trying to enable service when filesystem is not ready?
Trying to enable service when filesystem is not ready?
Status: CLOSED DUPLICATE of bug 679321
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
15
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-26 05:08 EST by Mamoru TASAKA
Modified: 2011-02-28 14:56 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-28 14:56:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
boot.log (9.17 KB, text/plain)
2011-02-26 05:08 EST, Mamoru TASAKA
no flags Details
Rebuilt of $ mount (3.05 KB, text/plain)
2011-02-26 05:09 EST, Mamoru TASAKA
no flags Details
/var/log/dmesg (45.29 KB, text/plain)
2011-02-26 05:17 EST, Mamoru TASAKA
no flags Details

  None (edit)
Description Mamoru TASAKA 2011-02-26 05:08:14 EST
Created attachment 481133 [details]
boot.log

Description of problem:
* In /var/log/boot.log, I see some peculiar messages like:
--------------------------------------------------
Calling the system activity data collector (sadc): /etc/rc.d/init.d/sysstat: line 27: /usr/lib/sa/sa1: No such file or directory
/etc/rc.d/init.d/isdn: line 10: id: command not found
/etc/rc.d/init.d/isdn: line 10: [: =: unary operator expected
/etc/rc.d/init.d/irqbalance: line 20: id: command not found
/etc/rc.d/init.d/irqbalance: line 20: [: =: unary operator expected
Determining IP information for eth0.../sbin/dhclient: error while loading shared libraries: libomapi.so.0: cannot open shared object file: No such file or directory
 failed.
[FAILED]
...
...
--------------------------------------------------

* Also, connecting to net fails after logging in tty2:
--------------------------------------------------
[root@localhost Date20110226-001]# koji latest-pkg dist-f15-updates-testing initscripts
gaierror: [Errno -2] Name or service not known
--------------------------------------------------
  After executing $ service network restart, network begins
  to work again.

It seems that systemd(?) tries to start services before needed
filesystem (/usr) gets mounted?

Version-Release number of selected component (if applicable):
systemd-18-1.fc15.i686
initscripts-9.25-1.fc15.i686
util-linux-2.19-3.fc15.i686

How reproducible:
100%

Steps to Reproduce:
1. Just reboot
Comment 1 Mamoru TASAKA 2011-02-26 05:09:28 EST
Created attachment 481134 [details]
Rebuilt of $ mount

Result of $ mount
Comment 2 Mamoru TASAKA 2011-02-26 05:17:47 EST
Created attachment 481136 [details]
/var/log/dmesg
Comment 3 Lennart Poettering 2011-02-28 14:56:27 EST
/usr is never mounted:

Starting /usr [1;31mfailed[0m, see 'systemctl status usr.mount' for details.


Under the assumption that this is a duplicate of 679321 I'll close this as duplicate now.

*** This bug has been marked as a duplicate of bug 679321 ***

Note You need to log in before you can comment on or make changes to this bug.