This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 680624 - An internal error
An internal error
Status: CLOSED DUPLICATE of bug 672932
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-26 09:36 EST by David
Modified: 2014-03-16 23:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-02-26 11:23:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description David 2011-02-26 09:36:20 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:  I was having trouble updating glbic to the latest version using software update.  I went to the terminal and ran upgrade from the root and this error came up after.
Error Type: <class 'yum.Errors.YumBaseError'>
Error Value: Error: rpmdb open failed
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3612, in <module>
    main()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 3608, in main
    backend = PackageKitYumBackend('', lock=True)
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 264, in __init__
    self.doLock()
  File : /usr/share/PackageKit/helpers/yum/yumBackend.py, line 350, in doLock
    self.yumbase.doLock(YUM_PID_FILE)
  File : /usr/lib/python2.7/site-packages/yum/__init__.py, line 1585, in doLock
    if self.conf.uid != 0:
  File : /usr/lib/python2.7/site-packages/yum/__init__.py, line 831, in <lambda>
    conf = property(fget=lambda self: self._getConfig(),
  File : /usr/lib/python2.7/site-packages/yum/__init__.py, line 277, in _getConfig
    startupconf = config.readStartupConfig(fn, root)
  File : /usr/lib/python2.7/site-packages/yum/config.py, line 859, in readStartupConfig
    startupconf.releasever = _getsysver(startupconf.installroot, startupconf.distroverpkg)
  File : /usr/lib/python2.7/site-packages/yum/config.py, line 1004, in _getsysver
    raise Errors.YumBaseError("Error: " + str(e))



Additional info:
[root@USB ~]# yum
rpmdb: Thread/process 2853/3077998272 failed: Thread died in Berkeley DB library
error: db3 error(-30974) from dbenv->failchk: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 -  (-30974)
error: cannot open Packages database in /var/lib/rpm
CRITICAL:yum.main:
Comment 1 Andy Lawrence 2011-02-26 11:23:57 EST

*** This bug has been marked as a duplicate of bug 672932 ***

Note You need to log in before you can comment on or make changes to this bug.