Bug 68063 - Kernel 2.4.9-34 does not support AMD VIPER 7441 ide chipset on Tyan 2468 GN
Summary: Kernel 2.4.9-34 does not support AMD VIPER 7441 ide chipset on Tyan 2468 GN
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: athlon Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-07-06 00:15 UTC by Nate Faerber
Modified: 2007-04-18 16:43 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-07 20:14:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
hdparm -iv /dev/hd[abc] (1.78 KB, text/plain)
2002-07-06 00:17 UTC, Nate Faerber
no flags Details
lspci -vv (5.22 KB, text/plain)
2002-07-06 00:19 UTC, Nate Faerber
no flags Details
dmesg (9.86 KB, text/plain)
2002-07-06 00:20 UTC, Nate Faerber
no flags Details
cat /proc/ide/hd[ab]/settings (3.48 KB, text/plain)
2002-07-06 00:21 UTC, Nate Faerber
no flags Details
hdparm -X69 /dev/hda; dmesg | tail (495 bytes, text/plain)
2002-07-06 00:23 UTC, Nate Faerber
no flags Details
hdparm -X66 /dev/hda;hdparm -iv /dev/hd[ab] (1.69 KB, text/plain)
2002-07-06 00:26 UTC, Nate Faerber
no flags Details
hdparm -X66 /dev/hda;dmesg | tail -20 (978 bytes, text/plain)
2002-07-06 00:26 UTC, Nate Faerber
no flags Details
patch to add support for amd7441 (4.31 KB, patch)
2002-07-18 20:48 UTC, Nate Faerber
no flags Details | Diff

Description Nate Faerber 2002-07-06 00:15:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.0 (X11; Linux i586; U;) Gecko/20020408

Description of problem:
There is no support for the VIPER 7441 ide chipset found on the Tyan 2468 GN in
the 2.4.9-34 kernel.  I have found that 7.3's 2.4.18-5 kernel has what appears
to be proper support but have not verified it. Booting the system with 2.4.9-34
loads the 'ide-disk' driver for this chipset and it does not properly recognize
DMA nor does it allow setting DMA levels.  The drives are WD800 and I have not
been able to test on different drives.

The system will lockup after repeated runs of Bonnie++.  I can usually run 10
iterations successfully then restart the test and only get to about 7 before the
sytem locks up completely.  After a soft reboot, Bonnie++ will run for around 4
iterations then after another soft reboot, only make 1 or 2 iterations.  It
seems to get progressively worse for some reason.  I have been able to boot a
newer custom kernel 2.4.18 (w/xfs) diskless (over a network before mounting the
local drives) and run the Bonnie++ benchmarks without any lockups.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Tyan s2468 GN
2. Install RedHat 7.2
3. Update to 2.4.9-34
4. Attempt to change DMA mode or do major file writes and rewrites in default
mode (using Bonnie++)

Actual Results:  System will hard lock presumably due to bad UDMA support in the
ide-disk driver.

Expected Results:  system stability

Additional info: I have attempted a backport of the support seen in the 2.4.18-5
kernel, but have been unsuccessful.

Comment 1 Nate Faerber 2002-07-06 00:17:49 UTC
Created attachment 63908 [details]
hdparm -iv /dev/hd[abc]

Comment 2 Nate Faerber 2002-07-06 00:19:22 UTC
Created attachment 63909 [details]
lspci -vv

Comment 3 Nate Faerber 2002-07-06 00:20:18 UTC
Created attachment 63910 [details]
dmesg

Comment 4 Nate Faerber 2002-07-06 00:21:36 UTC
Created attachment 63911 [details]
cat /proc/ide/hd[ab]/settings

Comment 5 Nate Faerber 2002-07-06 00:23:04 UTC
Created attachment 63912 [details]
hdparm -X69 /dev/hda; dmesg | tail

Comment 6 Nate Faerber 2002-07-06 00:26:04 UTC
Created attachment 63913 [details]
hdparm -X66 /dev/hda;hdparm -iv /dev/hd[ab]

Comment 7 Nate Faerber 2002-07-06 00:26:55 UTC
Created attachment 63914 [details]
hdparm -X66 /dev/hda;dmesg | tail -20

Comment 8 Nate Faerber 2002-07-06 00:28:33 UTC
Sorry for so many the attachments.  Just trying to cover all the bases.  Note
that the hdparm output is after booting with 'DMA=1' set in the
/etc/sysconfig/harddisks.  Otherwise DMA is not enabled.

Comment 9 Arjan van de Ven 2002-07-06 08:49:56 UTC
The right solution is to use the 2.4.18-5 kernel for such systems.

Comment 10 Nate Faerber 2002-07-18 20:48:59 UTC
Created attachment 65866 [details]
patch to add support for amd7441

Comment 11 Arjan van de Ven 2003-06-07 20:14:41 UTC
fixed in current erratum


Note You need to log in before you can comment on or make changes to this bug.