Bug 680645 - Avogadro crash on adding molecule
Avogadro crash on adding molecule
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
15
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-26 12:32 EST by v.plessky
Modified: 2014-01-21 18:17 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-04-02 10:56:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
crash details (62.40 KB, text/plain)
2011-02-26 12:32 EST, v.plessky
no flags Details
avogadro-crash - March 5, 2011 (62.66 KB, text/plain)
2011-03-05 03:36 EST, v.plessky
no flags Details
Comment (64.91 KB, text/plain)
2011-03-05 03:09 EST, v.plessky
no flags Details

  None (edit)
Description v.plessky 2011-02-26 12:32:46 EST
Created attachment 481164 [details]
crash details

Description of problem:

Did testing during X Test Week.
Avogadro crash on adding molecule

Version-Release number of selected component (if applicable):


How reproducible:

ALways

Steps to Reproduce:
1. Install Fedora15 image 20110226.02
2. Run Avogadro
3. Add molecule
  
Actual results:

Crash

Expected results:


Additional info:

Attached crash details.
All debug symbols have been installed (2.4GB unpacked !!)
Comment 1 Kevin Kofler 2011-02-26 21:23:39 EST
Crashes deep in mesa code. Nouveau driver in use. Reassigning.

Unfortunately, you seem to still miss some debug symbols though:
#0  0x00007fc397600068 in ?? ()
No symbol table info available.
#1  0x0000000001064ab0 in ?? ()
No symbol table info available.
#2  0x000000000106f060 in ?? ()
No symbol table info available.
[snip]
0x00007fc3a4f59590  0x00007fc3a57119cc  Yes (*)     /usr/lib64/dri/libllvmcore-2.8.so
[snip]
(*): Shared library is missing debugging information.

Are those symbols missing from mesa-debuginfo?
Comment 2 Kevin Kofler 2011-02-26 21:26:51 EST
The first usable stack frames:

#3  0x00007fc3a5dfc343 in fetch (output=<optimized out>, fetch_info=<optimized out>, fetch=<optimized out>) at draw/draw_pt_fetch_shade_pipeline.c:135
No locals.
#4  fetch_pipeline_generic (middle=0x12755c0, fetch_info=<optimized out>, prim_info=0x7ffffa97c360) at draw/draw_pt_fetch_shade_pipeline.c:227
        fpme = 0x12755c0
        draw = 0x190
        vshader = 0x12738e0
        gshader = 0x0
        gs_prim_info = {linear = 0 '\000', start = 0, elts = 0x0, count = 0, prim = 0, flags = 0, primitive_lengths = 0x0, primitive_count = 0}
        fetched_vert_info = {verts = 0x12755c0, vertex_size = 84, stride = 84, count = 400}
        vs_vert_info = {verts = 0x0, vertex_size = 0, stride = 0, count = 0}
        gs_vert_info = {verts = 0x0, vertex_size = 0, stride = 0, count = 0}
        vert_info = <optimized out>
        opt = 7
Comment 3 v.plessky 2011-03-05 03:09:03 EST
Created attachment 915196 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 4 v.plessky 2011-03-05 03:26:55 EST

Don't know if it's important or not - I have NVIDIA GT9600 Mobile video on this computer.

01:00.0 VGA compatible controller [0300]: nVidia Corporation G96 [GeForce 9600M GT] [10de:0649] (rev a1)


I also found that some missing debuginfo can be installe dby additional cvommands:

#debuginfo-install nss-softokn-freebl
#debuginfo-install ibus

don't know why ABRT not included those packages for crash detection.
Comment 5 v.plessky 2011-03-05 03:36:19 EST
Created attachment 482420 [details]
avogadro-crash - March 5, 2011


includes info with:
nss-softokn-freebl
ibus

debuginfo packages installed.
Comment 6 Matěj Cepl 2011-03-07 10:21:25 EST
This backtrace is still incomplete. Could you try to run 

debuginfo-install mesa

and regenerate the backtrace, please?

Thank you
Comment 7 v.plessky 2011-03-07 15:13:19 EST
# debuginfo-install mesa
Loaded plugins: auto-update-debuginfo, langpacks, presto, refresh-packagekit
Adding en_US to language list
enabling updates-testing-debuginfo
enabling fedora-debuginfo
No debuginfo packages available to install
Comment 8 Matěj Cepl 2011-03-18 11:46:57 EDT
Reassigning the bug to yum-utils, why debuginfo-install is not able to download all missing debuginfos?
Comment 9 Jan Kratochvil 2011-03-18 11:56:53 EDT
(In reply to comment #0)
> All debug symbols have been installed (2.4GB unpacked !!)

2.4GB looks like a valid unpacked size.

> warning: the debug information found in "/var/cache/abrt-di/usr/lib/debug//lib64/libfreebl3.so.debug" does not match "/lib64/libfreebl3.so" (CRC mismatch).

When any "CRC mismatch" message is present the backtrace can be bogus.  Please delete `/var/cache/abrt-di/*'.
Comment 10 Tim Lauridsen 2011-03-18 13:40:51 EDT
debuginfo-install mesa

Don't work because there is no package named mesa

$ sudo yum list \*mesa\*Loaded plugins: langpacks, presto, refresh-packagekit
Adding en_US to language list
Installed Packages
mesa-dri-drivers.x86_64                        7.9-5.fc14               @updates
mesa-libGL.x86_64                              7.9-5.fc14               @updates
mesa-libGLU.x86_64                             7.9-5.fc14               @updates
Available Packages
lilypond-parmesan-fonts.x86_64                 2.12.3-1.fc13            fedora  
mesa-demos.x86_64                              7.9-5.fc14               updates 
mesa-dri-drivers.i686                          7.9-5.fc14               updates 
mesa-dri-drivers-experimental.i686             7.9-5.fc14               updates 
mesa-dri-drivers-experimental.x86_64           7.9-5.fc14               updates 
mesa-libGL.i686                                7.9-5.fc14               updates 
mesa-libGL-devel.i686                          7.9-5.fc14               updates 
mesa-libGL-devel.x86_64                        7.9-5.fc14               updates 
mesa-libGLU.i686                               7.9-5.fc14               updates 
mesa-libGLU-devel.i686                         7.9-5.fc14               updates 
mesa-libGLU-devel.x86_64                       7.9-5.fc14               updates 
mesa-libGLw.i686                               6.5.1-8.fc12             fedora  
mesa-libGLw.x86_64                             6.5.1-8.fc12             fedora  
mesa-libGLw-devel.i686                         6.5.1-8.fc12             fedora  
mesa-libGLw-devel.x86_64                       6.5.1-8.fc12             fedora  
mesa-libOSMesa.i686                            7.9-5.fc14               updates 
mesa-libOSMesa.x86_64                          7.9-5.fc14               updates 
mesa-libOSMesa-devel.i686                      7.9-5.fc14               updates 
mesa-libOSMesa-devel.x86_64                    7.9-5.fc14               updates
Comment 11 v.plessky 2011-04-02 09:31:57 EDT
I can confirm that debug package 'mesa' is stil not available
Comment 12 Jan Kratochvil 2011-04-02 10:13:25 EDT
# repoquery -q --enablerepo='*debug*' mesa-debuginfo.x86_64
mesa-debuginfo-0:7.9-5.fc14.x86_64

There is no base package `mesa' but the debuginfo package name is derived from the base name.

use: debuginfo-install mesa-dri-drivers.x86_64

It will install mesa-debuginfo because:
# rpm -q --qf '%{sourcerpm}\n' mesa-dri-drivers.x86_64
mesa-7.9-5.fc14.src.rpm

You could also enable to right `debug' repositories and
# yum install mesa-debuginfo
Comment 13 v.plessky 2011-04-02 10:56:08 EDT
updated system via yum

with all packages as of today (Apr.2nd, 2011), I don't have crash on adding molecule.  System is x86_64.
Rotation also works.
So my guess crash has been fixed.

Note You need to log in before you can comment on or make changes to this bug.