Bug 680656 - [abrt] xorg-x11-server-Xorg-1.9.99.1-4.20101201.fc15: Process /usr/bin/Xorg was killed by signal 11 (SIGSEGV)
[abrt] xorg-x11-server-Xorg-1.9.99.1-4.20101201.fc15: Process /usr/bin/Xorg w...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
15
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
abrt_hash:f1d93f91dd1ce82478feb46efa3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-02-26 13:59 EST by Sergey
Modified: 2011-05-26 01:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-05-26 01:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (6.20 KB, text/plain)
2011-02-26 13:59 EST, Sergey
no flags Details

  None (edit)
Description Sergey 2011-02-26 13:59:36 EST
abrt version: 1.1.17
architecture: i686
Attached file: backtrace, 6345 bytes
cmdline: /usr/bin/Xorg :0 -br -verbose -auth /var/run/gdm/auth-for-gdm-2EDYOE/database -nolisten tcp
component: xorg-x11-server
Attached file: coredump, 7241728 bytes
executable: /usr/bin/Xorg
kernel: 2.6.38-0.rc5.git5.1.fc15.i686
package: xorg-x11-server-Xorg-1.9.99.1-4.20101201.fc15
rating: 3
reason: Process /usr/bin/Xorg was killed by signal 11 (SIGSEGV)
release: Fedora release 15 (Lovelock)
time: 1298822761
uid: 0

comment
-----
http://www.smolts.org/client/show/pub_1bd9b7cb-0031-4bdc-9885-ab1540ba820a
Only updates listed above were installed on gfx_test_week_20110221_i386.iso. Without mesa update mutter crashes on startup. Without nouveau update rotated display is not shown properly, but Xorg still crashes. Xorg updated to 1.9.99.1-6 is also crashed with that script.

How to reproduce
-----
0. Download gfx_test_week_20110221_i386.iso and boot
1. Install mesa update from RHBZ 677371
2. Install nouveau update from RHBZ 679505
3. Restart X (C-A-BS), login, open terminal and start rotating display in Displays preferences, or just run script:
for j in `seq 30`; do for i in right inverted left normal; do
xrandr --output DVI-I-1 --rotate $i; sleep 7; done; done

You may need to change "DVI-I-1" to a different value, check `xrandr` output for correct output name.
Script crashes Xorg faster without `sleep 7`.
Comment 1 Sergey 2011-02-26 13:59:38 EST
Created attachment 481175 [details]
File: backtrace
Comment 2 Sergey 2011-05-26 01:34:37 EDT
Cannot reproduce this with released Fedora-15-i686-Live-Desktop.iso. I guess it was fixed with new Xorg or new nouveau driver.

Note You need to log in before you can comment on or make changes to this bug.