Bug 680664 - rear-1.9.0-1.fc14.noarch RPM fails to properly unpack and/or update
Summary: rear-1.9.0-1.fc14.noarch RPM fails to properly unpack and/or update
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rear
Version: 14
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Gratien D'haese
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-26 19:59 UTC by Peter Trenholme
Modified: 2011-08-29 12:51 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2011-08-29 12:51:13 UTC


Attachments (Terms of Use)

Description Peter Trenholme 2011-02-26 19:59:43 UTC
Description of problem:
11:31:51 : YUM: Error unpacking rpm package rear-1.9.0-1.fc14.noarch

11:31:51 : RPM Scriptlet: warning: /etc/rear/local.conf created as /etc/rear/local.conf.rpmnew
11:31:51 : YUM: error: unpacking of archive failed on file /usr/share/rear/finalize/CentOS: cpio: rename



Version-Release number of selected component (if applicable):
1.9.0-1

How reproducible:
Every time

Steps to Reproduce:
1.yum update rear
2.
3.
  
Actual results:
11:31:51 : YUM: Error unpacking rpm package rear-1.9.0-1.fc14.noarch

11:31:51 : RPM Scriptlet: warning: /etc/rear/local.conf created as /etc/rear/local.conf.rpmnew
11:31:51 : YUM: error: unpacking of archive failed on file /usr/share/rear/finalize/CentOS: cpio: rename



Expected results:
Update success

Additional info:
We don't have a CentOS installation. Here's what is currently in /usr/share/rear/finalize/

$ ls -l /usr/share/rear/finalize/
total 40
drwxr-xr-x. 3 root root 4096 Dec 14 19:41 CentOS
lrwxrwxrwx. 1 root root    6 Feb 13 16:12 CentOS;4d5871db -> Fedora
lrwxrwxrwx. 1 root root    6 Feb 19 08:51 CentOS;4d5ff454 -> Fedora
lrwxrwxrwx. 1 root root    6 Feb 20 15:52 CentOS;4d61a91e -> Fedora
lrwxrwxrwx. 1 root root    6 Feb 25 12:41 CentOS;4d681260 -> Fedora
lrwxrwxrwx. 1 root root    6 Feb 26 11:31 CentOS;4d6954dd -> Fedora
drwxr-xr-x. 3 root root 4096 Dec 14 19:41 Debian
drwxr-xr-x. 2 root root 4096 Dec 14 19:41 default
lrwxrwxrwx. 1 root root    6 Dec 14 19:41 Fedora -> CentOS
lrwxrwxrwx. 1 root root    6 Dec 14 19:41 FedoraCore -> CentOS
drwxr-xr-x. 3 root root 4096 Dec 14 19:41 Gentoo
drwxr-xr-x. 3 root root 4096 Oct  7 02:15 GNU
drwxr-xr-x. 2 root root 4096 Dec 14 19:41 Linux-ia64
drwxr-xr-x. 2 root root 4096 Dec 14 19:41 Linux-ppc64
drwxr-xr-x. 3 root root 4096 Oct  7 02:15 NBU
drwxr-xr-x. 3 root root 4096 Oct  7 02:15 NETFS
lrwxrwxrwx. 1 root root    6 Dec 14 19:41 RedHatEnterpriseAS -> CentOS
lrwxrwxrwx. 1 root root    6 Dec 14 19:41 RedHatEnterpriseES -> CentOS
lrwxrwxrwx. 1 root root    6 Dec 14 19:41 RedHatEnterpriseServer -> CentOS
drwxr-xr-x. 3 root root 4096 Dec 14 19:41 SUSE_LINUX
lrwxrwxrwx. 1 root root    6 Dec 14 19:41 Ubuntu -> Debian

which suggests that the CentOS director as "master" was renamed to Fedora, and the link Fedora->CentOS was intended to be changed to CentOS->Fedora. Perhaps I should just do a "yum erase rear" and re-install. . .

Comment 1 Peter Trenholme 2011-02-27 20:00:59 UTC
I just ran a yum update on another Fedora installation (which also had the old rear installed on it) and noticed that the problem seemed to cascade. I don't know what the significance of the cascading problem might be, but it seems (to me) that a fix is needed.

Here's the extract from the yum log (note the "rear" in the first line):

$ sudo grep " te " /var/log/yum.log
Feb 27 11:43:31 spambayes: ts_done name in te is rear should be spambayes
Feb 27 11:43:32 python-BeautifulSoup: ts_done name in te is spambayes should be python-BeautifulSoup
Feb 27 11:43:32 krusader-debuginfo: ts_done name in te is python-BeautifulSoup should be krusader-debuginfo
Feb 27 11:43:35 glibc-debuginfo: ts_done name in te is krusader-debuginfo should be glibc-debuginfo
Feb 27 11:43:37 lohit-devanagari-fonts: ts_done name in te is glibc-debuginfo should be lohit-devanagari-fonts
Feb 27 11:43:38 system-config-users: ts_done name in te is lohit-devanagari-fonts should be system-config-users
Feb 27 11:43:38 openssl-debuginfo: ts_done name in te is system-config-users should be openssl-debuginfo
Feb 27 11:43:41 qt-debuginfo: ts_done name in te is openssl-debuginfo should be qt-debuginfo
Feb 27 11:43:44 krb5-libs: ts_done name in te is qt-debuginfo should be krb5-libs
Feb 27 11:43:44 alsa-lib: ts_done name in te is krb5-libs should be alsa-lib
Feb 27 11:43:45 libuuid: ts_done name in te is alsa-lib should be libuuid
Feb 27 11:43:45 audit-libs: ts_done name in te is libuuid should be audit-libs
Feb 27 11:43:46 libv4l: ts_done name in te is audit-libs should be libv4l
Feb 27 11:43:47 kernel: ts_done name in te is libv4l should be kernel
Feb 27 11:43:50 initscripts: ts_done name in te is kernel should be initscripts
Feb 27 11:43:51 util-linux-ng: ts_done name in te is initscripts should be util-linux-ng
Feb 27 11:43:52 libmount: ts_done name in te is util-linux-ng should be libmount
Feb 27 11:43:52 libblkid: ts_done name in te is libmount should be libblkid
Feb 27 11:43:53 nss-softokn-freebl: ts_done name in te is libblkid should be nss-softokn-freebl
Feb 27 11:43:53 glibc: ts_done name in te is nss-softokn-freebl should be glibc
Feb 27 11:43:55 shadow-utils: ts_done name in te is glibc should be shadow-utils
Feb 27 11:43:56 audit-libs: ts_done name in te is shadow-utils should be audit-libs
Feb 27 11:43:56 libuuid: ts_done name in te is audit-libs should be libuuid
Feb 27 11:43:57 glibc-common: ts_done name in te is libuuid should be glibc-common
Feb 27 11:43:58 nss-softokn-freebl: ts_done name in te is glibc-common should be nss-softokn-freebl
Feb 27 11:43:58 glibc: ts_done name in te is nss-softokn-freebl should be glibc
Feb 27 11:44:00 tzdata: ts_done name in te is glibc should be tzdata

Comment 2 Gratien D'haese 2011-02-28 10:16:28 UTC
(In reply to comment #0)
> Version-Release number of selected component (if applicable): 1.9.0-1
> 
> Actual results:
> 11:31:51 : YUM: Error unpacking rpm package rear-1.9.0-1.fc14.noarch
> 11:31:51 : RPM Scriptlet: warning: /etc/rear/local.conf created as
> /etc/rear/local.conf.rpmnew
> 11:31:51 : YUM: error: unpacking of archive failed on file
> /usr/share/rear/finalize/CentOS: cpio: rename

Please login at https://admin.fedoraproject.org/updates/ and use the latest rear-1.10.0 waiting on some karma, which should resolve your issues described above.
Thanks for reporting this.

> which suggests that the CentOS director as "master" was renamed to Fedora, and
> the link Fedora->CentOS was intended to be changed to CentOS->Fedora. Perhaps I
> should just do a "yum erase rear" and re-install. . .
That will work too. See the release Notes for details.

Comment 3 Gratien D'haese 2011-08-29 12:51:13 UTC
Bug report is now obsolete since update rear-1.11.0. We may close this one.


Note You need to log in before you can comment on or make changes to this bug.