Bug 68068 - g++296 misinterpets #include <string>
g++296 misinterpets #include <string>
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: compat-gcc (Show other bugs)
limbo
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-07-05 21:35 EDT by Nathan G. Grennan
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-07-06 01:11:07 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nathan G. Grennan 2002-07-05 21:35:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020625

Description of problem:
If a .cpp has   #include <string>   in it when using gcc 2.96 instead of gcc 3.1
the compile will fail.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Compile something with g++296

	

Actual Results:  Won't compile

Expected Results:  For it to compile

Additional info:

I am trying to compile Galeon 1.2.5-3 with g++296, because I have compiled
Mozilla 1.0.1-5 with g++296. I compiled Mozilla with g++296, because I want
backward compatibility with Mozilla plugins.

I changed

if [ ! -f configure ]; then
        CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%{prefix} \

and

else
        CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{prefix} \


to

if [ ! -f configure ]; then
HOST_CC=gcc296 HOST_CXX=g++296 CC=gcc296 CCC=g++296 CXX=g++296 \ 
        CFLAGS="$RPM_OPT_FLAGS" ./autogen.sh --prefix=%{prefix} \

and

else
HOST_CC=gcc296 HOST_CXX=g++296 CC=gcc296 CCC=g++296 CXX=g++296 \
        CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{prefix} \

in galeon-1.2.5.spec. So during the build of the rpm it would use gcc 2.96
instead of gcc 3.1.

The file in Galeon 1.2.5 that has #include <string> at the top in an if
statement is  src/mozilla/TOCProtocolHandler.cpp


The actual error message during the compile is


TOCProtocolHandler.cpp:33:23: /usr/include/mozilla-1.0.1/string is a directory
Comment 1 Nathan G. Grennan 2002-07-06 01:11:03 EDT
I was able to compile galeon-1.2.5-3 with the Mozilla 1.0.1-5 rpms I compiled
under Limbo on a RedHat 7.3 box.

Note You need to log in before you can comment on or make changes to this bug.