Bug 680683 - [abrt] system-config-printer-1.3.1-1.fc15: newprinter.py:1276:setNPButtons:AttributeError: 'NewPrinterGUI' object has no attribute 'printers'
Summary: [abrt] system-config-printer-1.3.1-1.fc15: newprinter.py:1276:setNPButtons:At...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-printer
Version: 15
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:eedcee0c
: 689336 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-02-26 23:21 UTC by John Reiser
Modified: 2011-03-29 03:49 UTC (History)
3 users (show)

Fixed In Version: system-config-printer-1.3.2-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-03-23 05:00:02 UTC


Attachments (Terms of Use)
File: backtrace (599 bytes, text/plain)
2011-02-26 23:21 UTC, John Reiser
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 734968 None None None Never

Description John Reiser 2011-02-26 23:21:25 UTC
abrt version: 1.1.17
architecture: i686
cmdline: /usr/bin/python /usr/share/system-config-printer/system-config-printer.py
component: system-config-printer
executable: /usr/share/system-config-printer/system-config-printer.py
kernel: 2.6.38-0.rc6.git4.1.fc15.i686
package: system-config-printer-1.3.1-1.fc15
reason: newprinter.py:1276:setNPButtons:AttributeError: 'NewPrinterGUI' object has no attribute 'printers'
release: Fedora release 15 (Lovelock)
time: 1298762240
uid: 500

backtrace
-----
newprinter.py:1276:setNPButtons:AttributeError: 'NewPrinterGUI' object has no attribute 'printers'

Traceback (most recent call last):
  File "/usr/share/system-config-printer/newprinter.py", line 2710, in on_entNPTNetworkHostname_changed
    self.setNPButtons ()
  File "/usr/share/system-config-printer/newprinter.py", line 1276, in setNPButtons
    checkNPName(self.printers, self.entNPName.get_text()))
AttributeError: 'NewPrinterGUI' object has no attribute 'printers'

Local variables in innermost frame:
nr: 0
self: <NewPrinterGUI object at 0xa3370a4 (newprinter+NewPrinterGUI at 0xa3f76b0)>

How to reproduce
-----
1. Add printer, JetDirect, choose from list, Brother, HL-5050
2. change location and short name
3. Next

Comment 1 John Reiser 2011-02-26 23:21:27 UTC
Created attachment 481202 [details]
File: backtrace

Comment 2 Jiri Popelka 2011-03-01 12:09:52 UTC
Thank you for the report.
Are you able to reproduce it or did it happen only once ?

*** This bug has been marked as a duplicate of bug 589793 ***

Comment 3 Tim Waugh 2011-03-07 14:51:43 UTC
Actually I think this is different to bug #589793.  This is occurring in a different class instance now, NewPrinterGUI.

Comment 6 Fedora Update System 2011-03-18 17:26:21 UTC
system-config-printer-1.3.2-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/system-config-printer-1.3.2-1.fc15

Comment 7 Jiri Popelka 2011-03-21 08:24:55 UTC
*** Bug 689336 has been marked as a duplicate of this bug. ***

Comment 8 Jiri Popelka 2011-03-21 08:25:24 UTC
Doesn't seem to be fixed in system-config-printer-1.3.2-1.fc15.
See bug #689336.

Comment 9 Tim Waugh 2011-03-22 16:54:40 UTC
If this is repeatable, it would be great to see the full output of:

system-config-printer --debug

for a run during which it happens.  Thanks.

I've committed a change which might fix it, but without the debug output it's hard to be sure.

Comment 10 Fedora Update System 2011-03-22 17:27:02 UTC
system-config-printer-1.3.2-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/system-config-printer-1.3.2-2.fc15

Comment 11 Fedora Update System 2011-03-23 04:59:34 UTC
system-config-printer-1.3.2-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Naresh V. 2011-03-24 09:40:31 UTC
Hi,

Sorry for the late response. Just noticed the new RPM from updates on my system, and tried to reproduce. Nothing crashes this time -- but the 'Apply' button in the last window doesn't result in anything. I ended up just closing the windows.

I can't find any logs in ~/.xsession-errors either.

Comment 13 Tim Waugh 2011-03-25 11:58:43 UTC
Naresh V: Please create another bug report, and attach the output of running this command from the terminal:

system-config-printer --debug

Thanks.

Comment 14 Naresh V. 2011-03-25 12:07:25 UTC
(In reply to comment #13)
> Naresh V: Please create another bug report, and attach the output of running
> this command from the terminal:
> 
> system-config-printer --debug

Hmm. Strange. Adding a printer worked fine (i.e. went upto the stage where it asked "Print test page?") when run from a gnome3 desktop.

This time it asked for authentication several times and asked me if I wanted to open up a couple of firewall ports.

My earlier runs were on the XFCE spin.

Should I (still) create another bug report with the debug output?

Comment 15 Tim Waugh 2011-03-25 12:20:11 UTC
If you can reproduce the problem described in comment #12 it would be useful to have another bug report for it, yes. Thanks.

Comment 16 Fedora Update System 2011-03-29 03:49:07 UTC
system-config-printer-1.3.2-2.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.